Jump to content


Photo

[nobug (kind of)] Toontrack Ezdrummer VST


  • This topic is locked This topic is locked
6 replies to this topic

#1 artmandg

artmandg

    Member

  • Normal Members
  • PipPip
  • 40 posts

Posted 20 October 2007 - 18:28

As the topic says, Renoise 1.9 RC1 crashes the ezdrummer GUI when trying to switch to the Claustrophobic and Twisted EZX kits only. I've attached the screenshot of what I'm talking about below:

Posted Image

I tried resaving the ezdrummer screens that it loads hoping it was a image file bug, but that did not resolve the issue.

I've searched the ezdrummer forums for this exact issue, and I can't even find anyone using Renoise as their host. No help there.

I've searched the Renoise forums for possible suggestions but found very little relating to this specific bug. I'd really like to see this fixed because I really enjoy the ease of use in creating professional drum tracks with ezdrummer. I am not a programmer, so I wouldn't even know where to begin. However, it does narrow it down a bit given the fact that it will only crash when switching to the kits mentioned above out of the remaining 5, which work perfectly.

Thank you!

#2 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 22 October 2007 - 10:57

Does this happen with RC2 as well?

Which version of EZDrummer are you using?

Quite a big bunch of fixes have been made since the EZDrummer 1.0 release:
http://www.toontrack...tm.aspx?m=18031

Does this also happen when loading an EZDrummer in a clean (new) song, or does this only happen with the song you are currently working on?

I will contact toontrack and ask them for help. There seems to be no demo version available, so I need to ask them for a developer testing version first...

Could you please also attach your Renoise log.txt file. You'll find it at:
C:\Documents and Settings\%username%\Application Data\Renoise\V1.9.0

#3 artmandg

artmandg

    Member

  • Normal Members
  • PipPip
  • 40 posts

Posted 23 October 2007 - 03:10

Unfortunately yes, it behaves in the exact same manner as RC1.

The different EZX kits facilitate a different pixel dimension and I'm noticing that the screen dimension for the two kits giving me GUI issues are larger than the rest.

I tried manually reducing the dimensions of the failing kits as a test but I still received the GUI crash.

BTW, I can't find that directory on my system, I'm on Vista 32, forgive my ignorance.

EDIT: I forgot to mention I loaded the EZdrummer 1.1 (I believe) patch that you mentioned with no positive results.

Thank you

Edited by artmandg, 23 October 2007 - 03:17.


#4 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 23 October 2007 - 13:16

Have contacted Toontrack now and am waiting for response.

Could you please test if the same crash happens in other VST hosts as well? Maybe this problem is Windows Vista related.

If you don't have any other host installed, you may want to download and use this small free test host: http://www.hermannse...ams/vsthost.zip (http://www.hermannseib.com/vsthost.htm).

The log.txt is at C:\Users\YOURLOGIN\AppData\Roaming\Renoise\V1.9.0 on Windows Vista. Sorry, forgot to mention that.

#5 artmandg

artmandg

    Member

  • Normal Members
  • PipPip
  • 40 posts

Posted 24 October 2007 - 03:42

Have contacted Toontrack now and am waiting for response.

Could you please test if the same crash happens in other VST hosts as well? Maybe this problem is Windows Vista related.

If you don't have any other host installed, you may want to download and use this small free test host: http://www.hermannse...ams/vsthost.zip (http://www.hermannseib.com/vsthost.htm).

The log.txt is at C:\Users\YOURLOGIN\AppData\Roaming\Renoise\V1.9.0 on Windows Vista. Sorry, forgot to mention that.


Low and behold it crashed the vsthost you linked too! I attached a screenshot. So it doesn't appear to be Renoise related afteral.

Attached Images

  • s2.jpg


#6 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 24 October 2007 - 10:19

Are you really sure that you have installed all EZDrummer upgrades then? 1.1.1 is the latest version.

Looking at there change logs, it seems that this is an old/already fixed bug of EZDrummer.

#7 RogueM

RogueM

    New Member

  • Normal Members
  • Pip
  • 1 posts

Posted 24 October 2007 - 14:17

Rogue from Toontrack here.

And yes that is a crash within EZdrummer due to a version not compatible with these 2 EZX-s (as indicated on the packaging).

thanks to this tread we'll however monitor closely compatibility in the future.

RM