Jump to content


Photo

Sample Is Clicking - Any Way To Remove?


  • Please log in to reply
6 replies to this topic

#1 RhythmSection

RhythmSection

    Member

  • Normal Members
  • PipPip
  • 16 posts

Posted 28 January 2011 - 21:20

I've posted a similar question before about bass, which was kindly resolved, but this time I'm triggering a sample and it's clipping when it comes in.

I've tried playing with volume in the instrument editor but it doesn't resolve the click - any ideas?

Here's the xrns file if that helps. Any help much appreciated.

#2 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5763 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 28 January 2011 - 21:29

It's clicking because the start of your bass sample is cut badly. It's not cut exactly on a zero-crossing, therefore you get the click from the DC offset. If you simply cut on the zero-crossing instead or apply a little fade to the beginning of the sample, then the problem goes away.

Ideally, you want any sample to start at a zero-crossing. You can help to ensure this by enabling snap to zero-crossings in the sample editor, or like I said, simply applying a quick fade to your cuts.


Fixed example:
clicking_fixed.xrns

Bad:
Posted Image

Good:
Posted Image

#3 RhythmSection

RhythmSection

    Member

  • Normal Members
  • PipPip
  • 16 posts

Posted 28 January 2011 - 22:58

Fantastic - works perfectly, thanks so much.

#4 rhowaldt

rhowaldt

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2259 posts
  • Gender:Male
  • Location:The Hague, Netherlands

Posted 28 January 2011 - 23:31

It's clicking because the start of your bass sample is cut badly. It's not cut exactly on a zero-crossing, therefore you get the click from the DC offset. If you simply cut on the zero-crossing instead or apply a little fade to the beginning of the sample, then the problem goes away.

thanks for that dblue, i was not aware of it. even though i usually fade in the first couple miliseconds of my samples, this is a good think to keep in the back of my mind.

specs: [cpu] AMD Turion64 X2 TL-56 1.80 Ghz [ram] 2Gb DDR2 [audio] Realtek HD [os] Win7 x86
gear: cheap-ass no-functions-whatsoever midi-keyboard, Zoom H4 recorder, MeeBlip
home: http://www.roaldblijleven.net (forever under construction)
renoise: http://roald.exul.nl...oise/cheatsheet
music: http://soundcloud.com/rhowaldt

#5 td6d

td6d

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1422 posts
  • Location:The Netherlands

Posted 29 January 2011 - 01:24

You might find it that the left and right channel don't share the same 0-cross. In that case I just cut to the closest-by and put a fade on it with the 'fade in' or sample editor option.

- God have mercy on your hipster soul. -


#6 marbangens

marbangens

    Member

  • Normal Members
  • PipPip
  • 29 posts

Posted 31 March 2018 - 17:03

I'v done this fade in but I have clicking anyway? It's a short stereo sample. It started to click when I eq the volume of the lower freq around 100 Hz, but if I lower that frequency the clicking disappear? Is this gain clip? 



#7 ΔBįSƧȔš ṼØȊÐƎ

ΔBįSƧȔš ṼØȊÐƎ

    Big Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPip
  • 509 posts
  • Gender:Male
  • Location:Terror Australis

Posted 07 April 2018 - 22:47

I often fade in/out samples, though I do also use the Autofade button; "Automatically inserts a quick fade at the beginning and end of a sample. Useful for preventing unwanted audio clicks."

It is located in the sample properties section of the sampler, just to the right of where it says 'Playback.'

 

3.1_sampler-sampleproperties.png


┷┯┷┯┷┷┗┯┷┯┷┗┯┷ Ŧh̢ƏRę̡ I̕§ ̛B̢ë̕ΔÜt¥ i̷Й͟ ͘È̷ЯRØŔ̵ ͠ ä₦Ð MɐĢ͟iƆ !Ṇ͢ ӍΔLℲuИ¢Ț̡ï̸Ѻп ┯┷┯┯┷┷┯┷┷┗┷┷┯  

┷┷┗┯┷┯┷┷┗┯┷┯┷┯┷┗┷┯┷┷┷┷┗┯┷┯┯┷┷┯┷┗┷┗vaeprism.com┷┷┗┯┷┯┷┷┗┯┷┯┷┯┷┗┷┯┷┗┷┗┷┯┷┷┗┷┯┷┗┯