Jump to content


Photo

[Nobug] Auto Adjust Master Volume Needed In 2.7 While Not In 2.6


  • This topic is locked This topic is locked
6 replies to this topic

#1 hokke

hokke

    Member

  • Normal Members
  • PipPip
  • 43 posts

Posted 25 April 2011 - 19:46

In this beta it's necessary to use auto adjust master volume with song which didn't need that in stable version.

#2 Guest_Jenoki_*

Guest_Jenoki_*
  • Guests

Posted 25 April 2011 - 20:17

Hello!

Do you have an example file that shows why you believe this is necessary?

#3 gmm04e

gmm04e

    Super Advanced Member

  • Normal Members
  • PipPipPipPip
  • 186 posts
  • Gender:Male

Posted 25 April 2011 - 21:12

do you have 'track headroom' in 'song setting' set to -6 db ?

#4 vV

vV

    God's or Borg's Chief and Ruler of All Species

  • Moderator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 16855 posts
  • Gender:Male
  • Location:Netherlands

Posted 25 April 2011 - 21:48

do you have 'track headroom' in 'song setting' set to -6 db ?


That supposed to be on -6.021dB by default. Unless the Hokke changed that.
Vv....


cpu Intel Core i7-4820K @3.70GHz
chipset Intel X79 chipset
mem 32 Gb 2400Mhz
os Win 7 64-bit SP1, DirectX 11
audio ESI ESP1010e - > Driver rev:2.0.6.0
video nVidia Geforce GTX780 - > Driver rev:335.23


Renoise Official Manual

#5 hokke

hokke

    Member

  • Normal Members
  • PipPip
  • 43 posts

Posted 26 April 2011 - 12:51

Hello, Jenoki, I believe that's necessary because clipping indicator goes red and so on... (it didn't do that with stable version) gmm04e, track headroom is set default -6.021dB

#6 Guest_Jenoki_*

Guest_Jenoki_*
  • Guests

Posted 26 April 2011 - 14:17

Okay, well I just did some test.

In Renoise 2.6.1:

I load up Chip Sine instrument. Maximise it in sample editor, change its amplitude to 6.021db in instrument settings.
I play the note and look at the master channel. The clipping indicator goes straight away red and the peak indicator says "0.01db"

In 2.7b7:
I load up Chip Sine instrument, Maximise it in sample editor, change its amplitude to 6.021db in instrument settings.
I change track headroom to -6.021db.
I play the note. The clipping indicator varies from clipping to normal, and the peak indicator says "0.00db"

Video: http://ge.tt/5L7nN5r

What does it mean?

Edited by Jenoki, 26 April 2011 - 14:24.


#7 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 27 April 2011 - 09:14

Okay, well I just did some test.

In Renoise 2.6.1:

I load up Chip Sine instrument. Maximise it in sample editor, change its amplitude to 6.021db in instrument settings.
I play the note and look at the master channel. The clipping indicator goes straight away red and the peak indicator says "0.01db"

In 2.7b7:
I load up Chip Sine instrument, Maximise it in sample editor, change its amplitude to 6.021db in instrument settings.
I change track headroom to -6.021db.
I play the note. The clipping indicator varies from clipping to normal, and the peak indicator says "0.00db"

What does it mean?


2.6 clipping indicators indeed where a bit wrong, which we've fixed in 2.7. So there may be a "slight" difference in the auto gain behavior. So this explains the 2.6 <> 2.7 behavior.

Clipping may also happen because of interpolation. Interpolation does change the shape of the original sample and thus also may change the peak values of the rendered audio. Try setting the interpolation mode of the attached sample to "None" and to "Linear" and "Cubic". With no interpolation, it will not clip, with interpolation, it may clip, also depending on the current playback samplerate.

Attached File  Interpolation_And_HeadRoom.xrns   4.82KB   6 downloads