Jump to content


Photo

[Nobug] Wav With Loop Import (Loop End One Sample Too Long)


  • This topic is locked This topic is locked
4 replies to this topic

#1 KanetonKiller

KanetonKiller

    Advanced Member

  • Normal Members
  • PipPipPip
  • 91 posts

Posted 03 May 2011 - 20:01

Hi everybody,

I've noticed on 2.7b7 (same in b6 & 2.6.1) that every WAV i try to import with a loop has their end point wrongly imported. I need to push "<" bouton one time (juste one time) to make loop corrected.

I haven't a lot of looped samples so maybe it's just this particulary pack (Cakewalk Dimension samples).

Everyone noticed that before or it's just me who need to find something less complicated to do ? ^^

Another time, sorry for my english, i feel it very bad tonight ^^




Edit : after some new test, i've the pleasure to say that some are ok. I'll investigate more about that...

Edited by KanetonKiller, 03 May 2011 - 20:14.


#2 mxb

mxb

    Big Super GrandMasta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 703 posts
  • Gender:Male

Posted 03 May 2011 - 20:46

Hi everybody,

I've noticed on 2.7b7 (same in b6 & 2.6.1) that every WAV i try to import with a loop has their end point wrongly imported. I need to push "<" bouton one time (juste one time) to make loop corrected.

I haven't a lot of looped samples so maybe it's just this particulary pack (Cakewalk Dimension samples).

Everyone noticed that before or it's just me who need to find something less complicated to do ? ^^

Another time, sorry for my english, i feel it very bad tonight ^^

Edit : after some new test, i've the pleasure to say that some are ok. I'll investigate more about that...


Hi,

I've not noticed this personally.

One simple check would be to load the wav files into an audio editor and see if the loop positions are the same as they are in Renoise. This should identify if the issue is Renoise or the wav file itself.

NB: If you don't have an audio editor wavosaur is small and free (Win only)
Is a footer a sweater for feet?

#3 KanetonKiller

KanetonKiller

    Advanced Member

  • Normal Members
  • PipPipPip
  • 91 posts

Posted 03 May 2011 - 20:53

Shame on me, haven't think to do that simple check ^^ (long work day, it's an excuse ?).

Look for that & paste the result here...



Great for the RC1 :w00t:


Edit : so after few tests, it seem's that the samples loads correctly in Fruity Loops & SoundForge.

On Fruity & Renoise, at the end point, the waveform seems to be one vertical line but SoundForge allow to see that's not the case.
SF has the end point at the end of the vertical line (upper side).

Renoise has the end point on the sample after (with crack) & Fruity seems to have it on one sample before (but not crack)

What i see is that SoundForge have 2 point for this line while Renoise & Fruity have only one...

Don't know if this could help & more than anything, don't know if someone can understand my english ^^

Edited by KanetonKiller, 04 May 2011 - 17:58.


#4 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 09 May 2011 - 15:19

Hey,

as long as things "sound" OK, it does not really make a difference at which spot in the sample editor they show up (behind or before the "real" loop end). From our tests the loops DO sound OK. If you have an example file which does not sound OK, would you mind sharing it and let us know in which other software they do sound different?

#5 KanetonKiller

KanetonKiller

    Advanced Member

  • Normal Members
  • PipPipPip
  • 91 posts

Posted 09 May 2011 - 18:45

After some more tests, i noticed that only the sample with a loop point on a "vertical line" (SF show that's not but Renoise display it as it is) have this problem resulting in some crack with some of them.

Here one of the sample who are concerned.

Juste move the end point one sample before & all cracks disapears.
This one has cracks on FL v.7 too but not on SoundForge.

Thanks to the team for looking at this "minor" issue.

Attached Files


Edited by KanetonKiller, 09 May 2011 - 18:56.