Jump to content


Photo

New Tool (2.8, 3.0): Renoise Freesound Integration


  • Please log in to reply
135 replies to this topic

#76 Shah

Shah

    Member

  • Normal Members
  • PipPip
  • 33 posts

Posted 16 October 2013 - 14:14

kk, ill try check it again at home. I dont think its something big, it just need some more tests on windows.
At least we came to same error on your and Dead Shadow computer - so thats a good start.
Ill post update later.


ok thanks, i hope we can get it to work on this machine, it's a great idea in principle.

#77 XXXXX

XXXXX

    New Member

  • Normal Members
  • Pip
  • 2 posts

Posted 22 October 2013 - 00:27

Hi, liked it, thanks! Need search history. Internal player will be great. Sorry if that was already mentioned.

#78 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 23 October 2013 - 22:32

ok, ive done some tests on windows and i have vlc working on my computer.

Version atached should work fine with vlc under windows - if someone with problem could confirm it ill merge it with normal version.
I also added Executableparams option in settings.xml (no gui yet) for aditional parameters to run windows software, didnt test it thou, ive only checked if vlc launch sample fine.

Attached Files


Edited by 29a, 23 October 2013 - 22:34.


#79 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 24 October 2013 - 12:02

ok, ive done some tests on windows and i have vlc working on my computer.

Version atached should work fine with vlc under windows - if someone with problem could confirm it ill merge it with normal version.
I also added Executableparams option in settings.xml (no gui yet) for aditional parameters to run windows software, didnt test it thou, ive only checked if vlc launch sample fine.

Can't install/drag and drop it in Renoise. When I try the cursor becomes a stop sign. Looking forward to try it.

#80 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 24 October 2013 - 19:37

Can't install/drag and drop it in Renoise. When I try the cursor becomes a stop sign. Looking forward to try it.

Opened the file as a zip. The files were located inside a folder. Moved them to the root. Now it works. Installable version attached.

And yes, vlc works (and it almost works with Winamp)!



An error. I search for "drum". Click next a few times (or maybe just one time), I get this:
main.lua:170: attempt to index field '?' (a nil value)
stack traceback:
  main.lua:170: in function 'success'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:1289: in function '_do_callback'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:925: in function '_read_content'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:121: in function <...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:75>

When previewing a file, the tool will leave a grey Renoise dialog containing the command executed ([Player location] + [file location]). Would be nice if every new preview would close the previous dialog. You have to close quite a lot of them when playing lots of sounds.

Also, as default maybe the file should be played in an open instance of vlc if one such exists. But I guess you can already make it behave like that if you master the Executableparams option in settings.xml.

Attached Files



#81 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 24 October 2013 - 20:55

Opened the file as a zip. The files were located inside a folder. Moved them to the root. Now it works. Installable version attached.

yeah, i figured out that might be a problem ;)

And yes, vlc works (and it almost works with Winamp)!

great, so i ll merge with main version

An error. I search for "drum". Click next a few times (or maybe just one time), I get this:

main.lua:170: attempt to index field '?' (a nil value)
stack traceback:
  main.lua:170: in function 'success'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:1289: in function '_do_callback'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:925: in function '_read_content'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:121: in function <...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:75>

i saw simmilar one error on windows version and it also happened only one time, but i think your error happened because you closed dialog before download finished.

Ill work on dialogs together with merging windows version, maybe ill just move messages into some "status bar"...
thanks for tests!

#82 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 24 October 2013 - 23:15

i saw simmilar one error on windows version and it also happened only one time, but i think your error happened because you closed dialog before download finished.

Yearh, it happens when pressing next or previous before all wave forms are shown (which might mean before the sounds are temporarily downloaded).

#83 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 25 October 2013 - 21:08

update with status bar and merged with windows version, i would apriciate any feedback.

Attached Files


Edited by 29a, 25 October 2013 - 21:09.


#84 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 25 October 2013 - 23:47

Previewing with VLC and no parameters, I get the same error message as when quickly clicking through sound pages (the one mentioned in a previous post). So it doesn't work with VLC.

main.lua:123: attempt to index a nil value
stack traceback:
  main.lua:123: in function 'success'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:1289: in function '_do_callback'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:925: in function '_read_content'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:121: in function <...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:75>


#85 Carbonthief

Carbonthief

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1083 posts
  • Gender:Male

Posted 26 October 2013 - 00:37

update with status bar and merged with windows version, i would apriciate any feedback.


I tried to set VLC as the player because it was opening a browser window by default, and it gave me this when I tried to preview a sample:

'C:\Users\Carbonthief\AppData\Roaming\Renoise\V2.8.1\Scripts\Tools\com.occulkot.Freesound.xrnx\main.lua' failed in one of its notifiers.
The notifier will be disabled to prevent further errors.

Please contact the author (Mateusz Ratajski [occulkot@gmail.com]) for assistance...

main.lua:123: attempt to index a nil value
stack traceback:
  main.lua:123: in function 'success'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:1289: in function '_do_callback'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:925: in function '_read_content'
  ...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:121: in function <...ise 2.8.1\Scripts\Libraries\renoise\http\request.lua:75>

edit: Just tried audacity, similar error. I should have left well enough alone...

edit2: After it pops that error, you have to relaunch renoise or it won't perform a search. I was able to undo my setting change though so I'm previewing sounds in google chrome, and it's working fine.

Edited by Carbonthief, 26 October 2013 - 00:44.


#86 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 26 October 2013 - 10:20

that one should work fine, ive changed a little os detection

Attached Files



#87 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 27 October 2013 - 12:27

that one should work fine, ive changed a little os detection

Works great! The browsing error is still there, though.

#88 KMaki

KMaki

    Big Super Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPip
  • 672 posts
  • Gender:Male
  • Location:Tampere, Finland
  • Interests:Survival (e.g. breathing). Small scale renoise-tool-coding. The Melvins. Absurdity of it all. Zen / Not-zen. Wifey&Kids.

Posted 31 December 2013 - 01:12

3.0?

:)

Pretty please? One of my very very basic go-to-tools, this one.
Renoise (2.6->) 2.8 / Mac mini 2010 - 2.66GHz Intel Core 2 Duo - 4 Gb 1067 MHz DDR3 / OS X 10.8 / M-Audio Fast Track USB

#89 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 03 January 2014 - 18:10

thanks for pointing, didnt knew that beta is released :D! Downloading and after first chill ill try to update for new version
  • KMaki likes this

#90 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 25 February 2014 - 21:32

sry for delay. 3.0 version ready for testing

Attached Files


  • hmā likes this

#91 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 25 February 2014 - 22:31

Renoise v. 3b6.
Player: VLC.
Save Directory set.
When previewing, I get this message:
main.lua:132: attempt to index a nil value
stack traceback:
  main.lua:132: in function 'success'
  ...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:1291: in function '_do_callback'
  ...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:925: in function '_read_content'
  ...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:121: in function <...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:75>


#92 capitán kazoo

capitán kazoo

    Advanced Member

  • Normal Members
  • PipPipPip
  • 119 posts
  • Gender:Male
  • Location:vienna

Posted 26 February 2014 - 00:24

please, can somebody help me... obviously i'm to stupid to get the preview function to work on osx. Posted Image

#93 Djeroek

Djeroek

    Probably More God or Borg Than Human Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6767 posts
  • Gender:Male
  • Location:Borneo

Posted 26 February 2014 - 00:51

getting this in windows vista 32, vlc as audio player;

'C:\Users\plugexpert\AppData\Roaming\Renoise\V3.0.0\Scripts\Tools\com.occulkot.Freesound.xrnx\main.lua' failed in one of its notifiers.
The notifier will be disabled to prevent further errors.

Please contact the author (Mateusz Ratajski [occulkot@gmail.com]) for assistance...

main.lua:132: attempt to index a nil value
stack traceback:
main.lua:132: in function 'success'
...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:1291: in function '_do_callback'
...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:925: in function '_read_content'
...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:121: in function <...ise 3.0.0\Scripts\Libraries\renoise\http\request.lua:75>



#94 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 26 February 2014 - 16:10

updated for windows detection

Attached Files



#95 slippycurb

slippycurb

    Big Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPip
  • 519 posts
  • Gender:Male
  • Location:Ireland Co Galway
  • Interests:My interests change from day to day, but i always like eggs.

Posted 26 February 2014 - 19:22

awsome
"No one would have believed, in the last years of the nineteenth century, that this world was being watched keenly and closely by intelligences greater than man's and yet as mortal as his own;"


SuckOnThisElectronicEgg


https://www.facebook...ristiansvslions

#96 Drop Shadow

Drop Shadow

    Big Daddy Member

  • Normal Members
  • PipPipPipPipPipPipPip
  • 441 posts
  • Gender:Male
  • Location:Copenhagen

Posted 26 February 2014 - 21:06

Great. It works.

#97 Djeroek

Djeroek

    Probably More God or Borg Than Human Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6767 posts
  • Gender:Male
  • Location:Borneo

Posted 27 February 2014 - 09:38

updated for windows detection


very nice, thanks!

Right now when downloading a sample into Renoise, the instrument name is blank. Could you update the instrument name to be the sample's name?

#98 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 27 February 2014 - 09:40

very nice, thanks!

Right now when downloading a sample into Renoise, the instrument name is blank. Could you update the instrument name to be the sample's name?

for empty instrument?, sure, why not, ill post update after work.

#99 29a

29a

    Member

  • Normal Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:/poland/lodz
  • Interests:Music (metal, speedcore), Audio, Programming

Posted 25 April 2014 - 22:24

Updated version with renaming namless instrument.

Attached Files



#100 odoyle

odoyle

    Member

  • Normal Members
  • PipPip
  • 39 posts

Posted 28 April 2014 - 22:31

On OSX 10.9.whatever, tool works great—except audio preview.

/Applications/VLC.app/Contents/MacOS/VLC --intf rc --run-time 15 --play-and-exit

VLC doesn't care. It just won't even launch. Paths are correct, permissions fine, etc.

Any ideas?