Jump to content


Photo

Undo


  • Please log in to reply
5 replies to this topic

#1 Sweeppah

Sweeppah

    New Member

  • Normal Members
  • Pip
  • 6 posts
  • Gender:Male

Posted 31 October 2013 - 20:41

Im using Renoise 64bit - V2.8.1 (built: Aug 15 2012) with windows 7. When i accidentally delete a channel and try to undo, the undo keeps saying 'Change Value' was undone." and nothing happens. Cant undo the channel delete (pattern data in that channel will be lost). Also if i look at the "edit" and see the undo button is greyd out after couple undo actions sometimes.

Is there a way to set how many undo actions Renoise keeps? or what actions it includes in undo?

edit:
Saved the song under a different name and loaded it up and renoise crashes when trying to load up the song.

edit2:
Using 32bit version doesnt have this problem

Edited by Sweeppah, 01 November 2013 - 19:25.


#2 vV

vV

    God's or Borg's Chief and Ruler of All Species

  • Moderator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 16855 posts
  • Gender:Male
  • Location:Netherlands

Posted 02 November 2013 - 22:18

Im using Renoise 64bit - V2.8.1 (built: Aug 15 2012) with windows 7. When i accidentally delete a channel and try to undo, the undo keeps saying 'Change Value' was undone." and nothing happens. Cant undo the channel delete (pattern data in that channel will be lost). Also if i look at the "edit" and see the undo button is greyd out after couple undo actions sometimes.

Is there a way to set how many undo actions Renoise keeps? or what actions it includes in undo?


Renoise should have unlimited undo levels.

Are you running Renoise scripts that might perform actions based on what you do?
Are you running LFO's that are consequently modifying DSP parameters?
These are conditions that interfere with the undo registration (your action can be undone, but it might be pushed back in the query by alteration recordings of an LFO changing parameters.)


edit:
Saved the song under a different name and loaded it up and renoise crashes when trying to load up the song.

edit2:
Using 32bit version doesnt have this problem


The 32-bit doesn't have this problem as in :it doesn't crash or the undo doesn't behave erratically?
Vv....


cpu Intel Core i7-4820K @3.70GHz
chipset Intel X79 chipset
mem 32 Gb 2400Mhz
os Win 7 64-bit SP1, DirectX 11
audio ESI ESP1010e - > Driver rev:2.0.6.0
video nVidia Geforce GTX780 - > Driver rev:335.23


Renoise Official Manual

#3 Sweeppah

Sweeppah

    New Member

  • Normal Members
  • Pip
  • 6 posts
  • Gender:Male

Posted 03 November 2013 - 16:20

Are you running Renoise scripts that might perform actions based on what you do?

I have no idea what Renoise scripts are.
edit: just looked up those and no im not using scripts yet =)

Are you running LFO's that are consequently modifying DSP parameters?

Yes im using two LFO's to modify filter values.

The 32-bit doesn't have this problem as in :it doesn't crash or the undo doesn't behave erratically?


I have been using 32-bit version after i noticed the funky stuff with undo and it works perfectly. It does not crash trying to load the song that crashes 64-bit version.

Edited by Sweeppah, 03 November 2013 - 16:30.


#4 vV

vV

    God's or Borg's Chief and Ruler of All Species

  • Moderator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 16855 posts
  • Gender:Male
  • Location:Netherlands

Posted 03 November 2013 - 21:36

I have no idea what Renoise scripts are.
edit: just looked up those and no im not using scripts yet =)


Yes im using two LFO's to modify filter values.



I have been using 32-bit version after i noticed the funky stuff with undo and it works perfectly. It does not crash trying to load the song that crashes 64-bit version.


If possible, could you perhaps share the xrns (as is) that crashes the 64-bit version? The crashing part is something that should not happen. Perhaps its a VST plugin that brings Renoise down, but from this angle, nobody knows for sure.
Vv....


cpu Intel Core i7-4820K @3.70GHz
chipset Intel X79 chipset
mem 32 Gb 2400Mhz
os Win 7 64-bit SP1, DirectX 11
audio ESI ESP1010e - > Driver rev:2.0.6.0
video nVidia Geforce GTX780 - > Driver rev:335.23


Renoise Official Manual

#5 Numtek

Numtek

    Member

  • Normal Members
  • PipPip
  • 45 posts
  • Gender:Male

Posted 01 May 2016 - 22:01

I had the same with the 64bit version, it said 'nothing to undo' or 'Change Value was undone'. Installing the 32bit version fixed this.

EDIT: ps sory for necroposting


Edited by Numtek, 01 May 2016 - 22:02.


#6 midi error

midi error

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1011 posts
  • Gender:Male
  • Location:The Chemical Plant Zone

Posted 12 May 2018 - 23:21

had this a few times myself - load the track i 32bit renoise and you have undo back!

 

worth mentioning i had this one time as one of the audio files was corrumpted