Jump to content


Photo

[fixed 3.1] Glide to note not consistent between instruments

glide Gxx

  • This topic is locked This topic is locked
2 replies to this topic

#1 RandomSkratch

RandomSkratch

    New Member

  • Normal Members
  • Pip
  • 4 posts
  • Gender:Male

Posted 14 October 2014 - 16:10

Was just messing around with commands and decided to have a look at Gxx. I thought I understood the command in that each increment raised by 1/16th of a note so G01 would pitch C-5 up 1/16th and G10 would pitch C-5 to C#-5. In practice I loaded up the drawbar organ that's included with Renoise and places C-4 on line 1 followed by C-5 G10 on a few lines down then followed with G00 to continue the glide to the point (I thought) it would finally reach C-5. When I hit play however, the pitch to C-5 was reached significantly sooner. In order to step up in semitones I needed to use G02.

 

Oddly enough, when I loaded the element MS20-Saw, G02 performed how I thought it would (pitching just barely - 2/16th) and G10 did the semitones.

 

Why are these two instruments affected differently? Is there something specified in the instrument parameters? Or have I discovered a bug?

 

 



#2 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5586 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 14 October 2014 - 16:29

Or have I discovered a bug?

Indeed, there's something fishy going on here. Thanks for reporting!

#3 RandomSkratch

RandomSkratch

    New Member

  • Normal Members
  • Pip
  • 4 posts
  • Gender:Male

Posted 15 October 2014 - 18:34

Oh wow I found a bug! You're welcome, hope it's nothing too serious!







Also tagged with one or more of these keywords: glide, Gxx