Jump to content


Photo

[fixed 3.1] (CDP) Lua tools may crash when importing 8ch WAV files


  • This topic is locked This topic is locked
2 replies to this topic

#1 Djeroek

Djeroek

    Probably More God or Borg Than Human Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6692 posts
  • Gender:Male
  • Location:Borneo

Posted 28 February 2015 - 16:00

Think I've made a similar bug report a while ago that never got addressed(?), can't find it real quick, but had a crash today using the cdp tool's reverb definition, setting an amount of output channels to something bigger > 2 , running the script gave;
 
Spoiler

 
Using a cdp tool version not out yet, but maybe this also happens with the latest version, or the quoted info is sufficient?

#2 afta8

afta8

    Big Super GrandMasta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 709 posts
  • Gender:Male
  • Location:London

Posted 01 March 2015 - 11:47

This doesn't happen on OSX, it's just on windows and occurs when you try to load a multichannel wav file via the API.

 

To replicate make sure you have a sample created in instrument 1, sample 1 and then run this command from the scripting terminal:

renoise.song().instruments[1].samples[1].sample_buffer:load_from(renoise.app():prompt_for_filename_to_read({"wav"},"load"))

Then try to load this file when the file selector pops up: https://www.dropbox....annels.wav?dl=0

 

I can get this to crash Renoise on Win8.1 



#3 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 02 March 2015 - 13:11

This doesn't happen on OSX, it's just on windows and occurs when you try to load a multichannel wav file via the API.


Thanks for reporting. Fixed this now here.