Jump to content


Photo

The top part of the scopes isnt functioning for muting tracks.


  • Please log in to reply
5 replies to this topic

#1 Luke

Luke

    Member

  • Normal Members
  • PipPip
  • 36 posts
  • Gender:Male
  • Location:Birmingham, UK

Posted 24 May 2015 - 10:18

As above. THe top part of the scopes isnt working for muting tracks either when you click the left or the right mouse button.

Basically clicking there isnt doing anything.

The Renoise I have is ver 3.0.0

Attached Images

  • bug.jpg

Edited by Luke, 24 May 2015 - 10:37.


#2 MurderatØr

MurderatØr

    Big Masta Member

  • Banned
  • PipPipPipPipPipPipPipPipPip
  • 528 posts
  • Gender:Male
  • Location:UK
  • Interests:Let's not MENTION ZE WAR! You MUST like Renoise, Ve hev vayz of making you comply. o/

Posted 24 May 2015 - 11:19

Without knowing the whole story, l am guessing the note attribute of "20 01" has something to do with it?


I aint a boffin though (dunno why it says "Super Advanced Member" lol)


My impact on the industry (one day): https://youtu.be/pTifdoKXoxM?t=1

#3 lhaastdaiz

lhaastdaiz

    Advanced Member

  • Normal Members
  • PipPipPip
  • 119 posts

Posted 24 May 2015 - 11:21

True, but it's handy for selecting tracks.



#4 toblerpone

toblerpone

    Guruh Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 905 posts
  • Gender:Not Telling
  • Location::c

Posted 24 May 2015 - 12:21

Increase the vertical size of the upper pane. Notice that in that  transparent row, on mouseover the track name becomes underlined, when you click on it, that track becomes selected.



#5 Luke

Luke

    Member

  • Normal Members
  • PipPip
  • 36 posts
  • Gender:Male
  • Location:Birmingham, UK

Posted 24 May 2015 - 15:31

Increase the vertical size of the upper pane. Notice that in that  transparent row, on mouseover the track name becomes underlined, when you click on it, that track becomes selected.

That actually does the trick gova, thanks ! But how come it is not working when the scopes are not big enough ? That should work whether the scopes are small or big. This is a buggy bug .


Edited by Luke, 24 May 2015 - 15:36.


#6 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5803 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 24 May 2015 - 16:08

The uppermost portion of the scope, where the track name appears, is reserved for selecting and changing to the track itself. As gova points out, when the track name becomes highlighted with an underline, then clicking on it will change to that track in the pattern editor.

The reason the hitbox occupies the entire scope width is because of potential situations like this:
renoise-scope-mute.png

When the scopes themselves are reduced (in height) to such a small size, it does indeed get quite cramped there, so it may be tricky to quickly find the different hot spots to click on.

What's your usual workflow when muting the tracks this way? Is it just generally turning tracks on and off while editing/previewing the pattern? Are you doing some live mute jamming to get an idea of a potential song build up?

In general, you may want to explore some of the key bindings for track mutes instead, rather than use the mouse exclusively. By default, you can use the left control key in combination with your numerical keypad numbers to toggle the first 9 tracks, or the hash (#) key to toggle the currently selected track's mute/off state (depending on which mute mode you prefer in your misc/plug preferences). Search the key binding preferences for "mute" to find more.