Jump to content


Photo

Activating Scripting Tools Help!

Activating Scripting Tools

  • Please log in to reply
8 replies to this topic

#1 Sniff

Sniff

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 13 October 2015 - 23:34

Hi all,
 
This is my first post and it is probably going to sound ridiculous.. but..
 
I have tried and tried to activate the tools within Renoise but really cant figure out how to do it!!

 

Its driving me crazy and me reaching out is my only option after searching on here for an answer.. (Maybe I havent looked hard enough but I am pretty sure i have!)

 

By default Renoise has all scripting utilities hidden; to keep things as easy as
possible for those who don't want to mess around with code. If you want to write
scripts, then the first thing you have to do is enable the hidden development
tools that are built into Renoise. This can be done by:

- Launching the Renoise executable with the argument "--scripting-dev"

- Opening Renoise's config.xml file from the preferences folder, and setting the
  <ShowScriptingDevelopmentTools> property to "true". This way, you don't have
  to pass the above mentioned argument every time you launch Renoise.

 


 

This is what I cannot figure out.. I have tried running all sorts of things using the terminal (Not even sure if that is even what i need to do haha)

 

I am on a Mac, Obviously any help would be very much appreciated as I am struggling lol

 

Thank you

Regards,

 

 


I've Got More Bars Than The Italian Job.

#2 Neurogami

Neurogami

    Big Super Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPip
  • 619 posts
  • Gender:Male
  • Location:Scottsdale AZ
  • Interests:Art, music, technology

Posted 14 October 2015 - 03:01

What exactly haven't you figured out?   What exactly have you tried?

 

Have you located your Config.xml file?

 

Did it have that XML element?

 

Did you set the text value to true?

 

Did you try running Renoise from the command line with the --scripting-dev  argument?



#3 Sniff

Sniff

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 14 October 2015 - 07:30

Thanks for the fast reply!

Basically I'm not too familiar with running programmes from the command line, I tried a number of different things which I found online, thinks like..

"open /Applications/Renoise_regarding.app/Contents/MacOS/Renoise --scripting-dev"

I've tried many variations of this but none of them worked and I wasn't sure that I was even going in the right direction with it!

I have tried to find the config.XML within the package contents of renoise itself.. like I said not sure if this is where it even is..

Really frustrating as I have been using renoise for almost 8 years and never knew this scripting even existed untill recently and really want to dive in and try and figure it out with very little experience in scripting (clearly as I can't work the terminal properly haha) but yeh.. really want to figure it out!

Thanks for your help! Much appreciated
I've Got More Bars Than The Italian Job.

#4 Beatslaughter

Beatslaughter

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2296 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:Music, Blu-ray, PC Games

Posted 14 October 2015 - 14:16

Not on MAC here but this should work for you. Start Renoise, go to 'Help' menu and select 'Show the preferences folder', open the file 'Config.xml' with a text editor, search for 'ShowScriptingDevelopmentTools' and change the value from 'false' to 'true', so it looks like this '<ShowScriptingDevelopmentTools>true</ShowScriptingDevelopmentTools>', save the config file and restart Renoise. Now you should have a new menu entry in the 'Tools' menu.


  • Ledger and Neurogami like this

#5 danoise

danoise

    Probably More God or Borg Than Human Member

  • Renoise Team
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6473 posts
  • Gender:Male
  • Location:Berlin
  • Interests:wildlife + urban trekking

Posted 15 October 2015 - 15:11

Once enabled, this is what the tool menu should look like:
renoise_tool_menu.png?raw=1
  • Ledger likes this

Tracking with Stuff. API wishlist | Soundcloud


#6 Sniff

Sniff

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 16 October 2015 - 10:00

Just opened up the config.xml from the Show the preferences folder and changed the "false" to "true" like you said,

 

Worked a treat 

 

thanks for the help!

 

Lewis


I've Got More Bars Than The Italian Job.

#7 Kommandotolken

Kommandotolken

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 12 June 2017 - 19:48

I am also on a mac and tried to change the xml file, however, when I restart renoise the config file resets. Does anyone know why it is? I have managed to do this before.



#8 4Tey

4Tey

    Chief Above Chief Member

  • Normal Members
  • PipPipPipPipPipPip
  • 384 posts
  • Gender:Male

Posted 12 June 2017 - 20:08

Kommandotolken:  Just to eliminate something:  You are modifying/saving the config file while Renoise is not running in the background?  As a quit from Renoise may overwrite the config file, undoing your modification.



#9 DusX

DusX

    Member

  • Normal Members
  • PipPip
  • 12 posts

Posted 12 June 2017 - 22:27

I was having the same issue as Kommandotolken on PC.

Closing Renoise, then editing the file and saving, before relaunching Renoise solved the problem 


  • Conner_Bw likes this