Jump to content


Photo

[fixed] OSX: Hotplugging audio interfaces doesn't work (until rest


  • Please log in to reply
3 replies to this topic

#1 todkon

todkon

    Member

  • Normal Members
  • PipPip
  • 15 posts
  • Gender:Not Telling

Posted 16 January 2016 - 22:54

Hey there, since the Renoise 3.1 betas and onward to stable release, it doesn't reintialize when I plug in my iPhone via StudioMux or my Focusrite Scarlett 2i4 audio interfaces in the settings pane. I basically have to quit and reload Renoise for the audio interfaces to be usable :(



#2 taktik

taktik

    Renoise Developer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 15040 posts
  • Gender:Male
  • Location:Berlin, Germany
  • Interests:füße waschen

Posted 18 January 2016 - 16:54

There's a hidden option for this in the preferences to turn the feature on/off, and it got turned off by default by accident during the betas. We'll fix this, but for now you can manually enable it again too:

* Open Renoise
* Click on "Help" -> "Show the Preferences Folder..."
* Close Renoise again (else it will overwrite the changes that you will do)
* Open Config.xml with a text editor
* Search for "<AutoRescanDevices>"
* there will be two <AutoRescanDevices>. One for MIDI, one for Audio. Set the one for audio to true -> <AutoRescanDevices>true</AutoRescanDevices>

#3 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2869 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 18 January 2016 - 19:02

Thx for that info. Do "UseHardwareBuffers", "UseRealTimePriority" and "NumberOfBuffer" also affect the OSX version?


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#4 todkon

todkon

    Member

  • Normal Members
  • PipPip
  • 15 posts
  • Gender:Not Telling

Posted 19 January 2016 - 21:03

@taktik Awesome! Thanks a bunch for the reply, worked like a charm :).


Edited by todkon, 19 January 2016 - 21:04.