Jump to content


Photo

[fixed] Glide command and volume control problems


  • Please log in to reply
3 replies to this topic

#1 MattD

MattD

    Advanced Member

  • Normal Members
  • PipPipPip
  • 117 posts
  • Gender:Male

Posted 18 January 2016 - 05:37

I'm including a small XNRS demonstrating the problem.

 

I've only tested this on 3.1.0.

 

I noticed this when a glide made a note louder, but I think something else might be going on with multiple volume samples and adjusting volume.

 

The instrument here was generated by Renoise's render plugin to instrument feature.

Attached Files


Edited by taktik, 04 March 2016 - 15:18.

KernUo9.png


#2 detektiv_plok

detektiv_plok

    Member

  • Normal Members
  • PipPip
  • 28 posts
  • Gender:Male
  • Location:Kiel, Germany

Posted 18 January 2016 - 11:09

Hi, I think you have to activate the velocity mapping in the keyzones tab. Works correctly here when activated.


Edited by detektiv_plok, 18 January 2016 - 11:12.


#3 MattD

MattD

    Advanced Member

  • Normal Members
  • PipPipPip
  • 117 posts
  • Gender:Male

Posted 18 January 2016 - 14:08

Thanks, detektiv_plok, I didn't notice that it was disabled. I didn't know that's what Render Plugin to Instrument would do since I don't usually render multiple with multiple velocities. If that's the intended behavior, then it might not be a bug.

 

Some of the behavior demonstrated still seems weird. Disabling the velocity mapping seems to behave in an asymmetrical way depending on whether you began loud or quiet.


Edited by MattD, 18 January 2016 - 14:11.

KernUo9.png


#4 detektiv_plok

detektiv_plok

    Member

  • Normal Members
  • PipPip
  • 28 posts
  • Gender:Male
  • Location:Kiel, Germany

Posted 19 January 2016 - 09:44

Yes, you're right. When velocity mapping is disabled, the initial volume state of a pattern note seems to determine how subsequent volume changes are interpreted. For initial values in the volume column smaller than 80, a subsequent volume increase actually results in a decreasing volume.

This also happens when the volume is changed via the MXX pattern command, but here altering the value for a specific note also produces a click. Doesn't happen with velocity mapping enabled. In the manual, MXX is not described as a sample note volume command by the way.

Attached Files


Edited by detektiv_plok, 19 January 2016 - 10:17.