Jump to content


Photo

Linux HiDPI & Pulseaudio - A Success Story

hidpi pulseaudio linux ubuntu compiz wine

  • Please log in to reply
1 reply to this topic

#1 chummm

chummm

    New Member

  • Normal Members
  • Pip
  • 4 posts

Posted 27 July 2016 - 06:26

Since installing Ubuntu on my 2014 Macbook Pro w/Retina display I had two major gripes with Renoise:

 

1. No pulseaudio output without doing weird shit like abusing alsa loopback (xruns everywhere) or sensible shit like setting up jack (no excuses here, just not for me).

2. Poor HiDPI support - Renoise basically illegible & unusable on 2880x1800 display @ 220ppi

 

Today I think I finally have this sorted out, at least to my satisfaction. FWIW these are both pretty hack solutions in their own right but they work for me :)

 

To fix "no pulseaudio output":

Just run Renoise in Wine. In preferences you will see a "Pulseaudio" audio output option. All audio from your other applications will continue to work.

 

To fix "poor hidpi support":

NOTE: This is an Ubuntu-specific solution, sorry!

Install compiz-plugins to get "Enhanced Zoom Desktop" (http://wiki.compiz.org/Plugins/Ezoom)

Install compizconfig-settings-manager to configure the plugin (https://apps.ubuntu....ttings-manager/)

Bind keys to "Zoom In", "Zoom Out" and "Toggle Zoom Area Lock"

 

So my flow is:

Run Renoise in Wine from desktop shortcut

Zoom in to Wine's configured resolution

Lock zoom

Produce

 

Hope this helps somebody! I wish there were improved support for these items in Renoise but I understand that both of the issues I experienced stem from deeper issues in the Linux community.



#2 blitzblitzblitz

blitzblitzblitz

    New Member

  • Normal Members
  • Pip
  • 1 posts

Posted 10 April 2018 - 20:48

I find unacceptable no hidpi support on any software. Most on linux on it is very easy to configure.

Please solve this or i will fallback to other software.







Also tagged with one or more of these keywords: hidpi, pulseaudio, linux, ubuntu, compiz, wine