Jump to content


Photo

Why can't I edit patterns correctly?

Patterns Automation Advanced Edit Pattern Editor

  • Please log in to reply
1 reply to this topic

#1 calypso

calypso

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 28 October 2016 - 00:12

Hello,

 

I've been trying to do a fade-in at the start of my song, and figured I could do this on the master track on the first pattern. However, no matter which option I select in the advanced edit panel on the right, it keeps repeating the automation in the exact same way. I've attached a picture to illustrate what I mean by this.

 

If anyone could help provide some further insight into what I'm doing wrong here, I'd be very grateful :)

 

 

Attached Images

  • screen.png


#2 Zer0 Fly

Zer0 Fly

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1257 posts
  • Gender:Not Telling
  • Location:Am Mind
  • Interests:Buddha

Posted 28 October 2016 - 00:33

I can tell you what you are doing wrong. Automation is bound to a pattern number, and you repeat the patterns.

 

look at the pattern matrix to the left, the 2nd box column with numbers is the pattern numbers. You are repeating 0,1,2 and 3. In pattern 0 you have the fade-in, and it is bound to pattern 0 and thus repeated every time it occurs.

 

In this kind of workflow, you could select all patterns but the first 0, select "organize->make unique" which will give them new numbers, and then delete the automation from all patterns but the first.

 

Arranging songs in renoise rather goes like...you copy or alias the track's contents to "fresh" patterns. Only repeat a pattern number if you want everything in it to repeat by 100%. Of course many ways lead to rome, so your idea wasn't that wrong maybe if you use the make unique function.


  • Achenar likes this






Also tagged with one or more of these keywords: Patterns, Automation, Advanced Edit, Pattern Editor