Jump to content


Photo

[solved] DB, Wave and Mixer Displays Lagging

Lag Display

  • Please log in to reply
4 replies to this topic

#1 Roms

Roms

    Member

  • Normal Members
  • PipPip
  • 25 posts

Posted 19 November 2016 - 00:37

Hi everyone, im running Renoise 3.1.0. I have ran it on my laptop which is pretty high spec for a long time now with no issues.

However since the other night I have noticed that all the displays which show the sound, such as the mixing window and db meter at the top are all lagging, I have tried rebooting renoise and my laptop but it hasn't helped.

There is no issue at all with the sound of the tracks but the displays are all running slightly off timing wise... :wacko:

Any ideas on how to fix this would be appreciated. Thanks :walkman:



#2 Roms

Roms

    Member

  • Normal Members
  • PipPip
  • 25 posts

Posted 20 November 2016 - 13:39

Any Mods that can help?



#3 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5832 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 20 November 2016 - 14:38

Are you running on Windows, Mac, or Linux?


Take a look at your audio preferences.

If your audio latency is set quite high, then you'll probably notice some lag in the VU meters and stuff, since those are being calculated based on the size of your audio buffers.

Higher latency = larger buffers = more VU/scope lag.


You can also take a look at your GUI preferences.

Perhaps you have your framerate limiter set to a low value there?

Perhaps you can try toggling some of the options to see if performance improves?


Otherwise, try to think back to what might happened on your system the other night.

Maybe your OS was updated? Maybe your graphics drivers were updated? Maybe something else happened?
  • Roms likes this

#4 Roms

Roms

    Member

  • Normal Members
  • PipPip
  • 25 posts

Posted 20 November 2016 - 20:01

Thanks a lot for your reply I will try everything and report back! @dblue

I am running on Mac, but I haven't changed anything and refuse to update my mac, still running yosemite. Maybe I changed something by accident while configuring sound output to my AI.


Edited by Roms, 20 November 2016 - 20:03.


#5 Roms

Roms

    Member

  • Normal Members
  • PipPip
  • 25 posts

Posted 21 November 2016 - 15:42

Are you running on Windows, Mac, or Linux?


Take a look at your audio preferences.

If your audio latency is set quite high, then you'll probably notice some lag in the VU meters and stuff, since those are being calculated based on the size of your audio buffers.

Higher latency = larger buffers = more VU/scope lag.


You can also take a look at your GUI preferences.

Perhaps you have your framerate limiter set to a low value there?

Perhaps you can try toggling some of the options to see if performance improves?


Otherwise, try to think back to what might happened on your system the other night.

Maybe your OS was updated? Maybe your graphics drivers were updated? Maybe something else happened?

Thank you so much, I was getting depressed because I couldn't make any music wit the VU/Scope bugging me!

My latency setting was 93 for some reason I dropped it to 40 and now everything is bang on! thanks again







Also tagged with one or more of these keywords: Lag, Display