Jump to content


Photo

Sierra 10.12.1 and VSTs not working (AUs working though)


  • Please log in to reply
9 replies to this topic

#1 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 11 December 2016 - 23:53

I just updated to Sierra 10.12.1 and now some VST windows aren't working in Renoise 3.1.

 

Sugar Bytes' Obscurium's window will open, but show no graphical display. Same thing with Rob Papen's Punch. Phonec 2 from Psychic Modulation won't open at all.

 

All three work in Cubase Elements 9 (the reason I updated to Sierra).

 

I've tried rescanning, and also deleting and reloading the VST from the instrument slot. Even tried rebooting the system. Would like to get these functional in Renoise again. :(

 

EDIT:

 

See photo in post below that shows blank VST window. Also, I tried the AU version (forgot you can activate them in Renoise) and they work.


Edited by grape_ape, 13 December 2016 - 23:14.


#2 Raul (ulneiz)

Raul (ulneiz)

    Guruh Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 820 posts
  • Gender:Male
  • Location:Spain

Posted 12 December 2016 - 00:21

I just updated to Sierra 10.12.1 and now some VSTs windows aren't working in Renoise 3.1.

 

Sugar Bytes' Obscurium's window will open, but show no graphical display. Same thing with Rob Papen's Punch. Phonec 2 from Psychic Modulation won't open at all.

 

All three work in Cubase Elements 9 (the reason I updated to Sierra).

 

I've tried rescanning, and also deleting and reloading the VST from the instrument slot. Even tried rebooting the system. Would like to get these functional in Renoise again. :(

 

Try to save everything you need to keep, and then uninstall Renoise and install again, without reinstalling any VSTs. Maybe this way the VSTs reappear, although I do not think it's the cause.

 

However, it is possible that the problem is of the VST registry itself in the operating system, and has nothing to do with Renoise. It is very possible. The solution is to re-register the VSTs (no need to uninstall, only register). If in the end all this does not work, uninstall and install the VSTs again.

 

When you install a new operating system version, the system can clean part of the registry of some programs (the VSTs) and it is necessary to register them again (the key).

 

Steps:

  1. Registers failing VSTs again and try
  2. if it does not work, install the VSTs again and try
  3. if it does not work, install Renoise again and try

Edited by Raul (ulneiz), 12 December 2016 - 00:25.

:excl: Development of my tool: GT16-Colors

 

:excl: My API wishlist:

Spoiler

 

:excl: My Renoise wishlist:

Spoiler

#3 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 12 December 2016 - 01:37

Thanks for the reply, unfortunately none of those worked.



#4 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 13 December 2016 - 02:46

Here's a screenshot, in case that helps.

 

Maybe Renoise is just jealous that I've added Cubase? ^_^

 

Seriously though, I'd like to get Renoise functional again with these VSTs!

 

The screenshot shows Obscurium on the left and Punch on the right, and as I say Phonec 2 doesn't open at all.

 

Screen Shot 2016-12-12 at 5.41.16 PM.png



#5 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2839 posts
  • Gender:Not Telling
  • Interests:Renoise Sidechain

Posted 13 December 2016 - 11:51

Are you using an hackintosh or a real mac? Just asking, because on hackintosh, if your gfx driver/kext wasn't injected properly, it simply could be disabled and the software gfx driver is running. Then it could happen that all opengl driven guis will not work.

 

Also this looks more like a problem of the plugin vendors, are you sure they announced Sierra compatibility?



#6 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 13 December 2016 - 14:36

Are you using an hackintosh or a real mac? Just asking, because on hackintosh, if your gfx driver/kext wasn't injected properly, it simply could be disabled and the software gfx driver is running. Then it could happen that all opengl driven guis will not work.

 

Also this looks more like a problem of the plugin vendors, are you sure they announced Sierra compatibility?

 

It's a Mac mini, late 2014 model, and as noted in the first post all three VSTs work fine in Cubase Elements 9.



#7 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2839 posts
  • Gender:Not Telling
  • Interests:Renoise Sidechain

Posted 13 December 2016 - 16:11

Ups, sorry. Out of ideas then. Did you check if Cub 9 uses the VST3 versions?  If so, you could deactivate VST3 in Cub9 and use the VST2 versions just like in Renoise and see, if that also works in Cub or not.



#8 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 13 December 2016 - 23:12

Ups, sorry. Out of ideas then. Did you check if Cub 9 uses the VST3 versions?  If so, you could deactivate VST3 in Cub9 and use the VST2 versions just like in Renoise and see, if that also works in Cub or not.

 

There's no VST3 version for the plug-ins not working. However, this reminded me that there is the AU version. Just tried it, and they work! Thread title updated.

 

I still wonder about the VST versions though, and think the Renosie team should probably look into this.


Edited by grape_ape, 13 December 2016 - 23:15.


#9 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 15 December 2016 - 07:53

Updated to Sierra 10.12.2 thinking it might fix the issue, ends up wiping out my entire display: just a cursor on a black screen. Apple Support was no help, denying it was an issue, even with others reporting it on various forums. Ended up having to erase my HD and install from scratch.

FFS Apple, get your sh!t together.

Edit: And no the fresh OS install didn't fix this VST issue.

Edited by grape_ape, 15 December 2016 - 07:55.


#10 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 14 March 2017 - 11:38

Actually got an error message when trying a PSP Audioware EQ demo, and yes still a blank window. I'm up to Sierra 10.12.3 at this point. Between this, MicroTonic MIDI routing not working, and Korg Wavestation VST constantly crashing (unrelated to Renoise) I've been having a ton of fun with bugs! :w00t:

 

psp.png