Jump to content


Photo

Duplex: "Pass unhandled MIDI messages to Renoise" doesn't

DUPLEX Pass unhandled MIDI messages Issue Does not work

  • Please log in to reply
3 replies to this topic

#1 jrod420

jrod420

    New Member

  • Normal Members
  • Pip
  • 8 posts

Posted 24 February 2017 - 23:17

Hey,

 

I'm a new user to Renoise and got my first problem, that I'm not able to solve - maybe I did something wrong?

 

 

Description:

 

I use the renoise tool "Duplex" to connect my midi controller (controller name: Akai APC40, Renoise runs on Linux). In the Duplex preferences I checked the ceckbox "Pass unhandled MIDI messages to Renoise" but it seems to have no effect.


Steps to reproduce:

1) Launch Renoise

2) physically connect a MIDI-controller (e.g. the APC40)
3) Start Duplex: Tools -> Duplex -> select any template that uses less buttons than the hardware MIDI-controller e.g. APC40

4) in the Duplex Browser: Select the Midi-Controller as In- and Out-device.
4) in the Duplex Browser: Settings -> check checkbox "Pass unhandled MIDI messages to Renoise"

5) activate MIDI-Mapping (=Learn Mode) in Renoise and select any parameter of a plugin (=red areas).
6) press a button on the MIDI-controller that is not used by Duplex

 

 

Expected results:

The pressed button on the MIDI-controller should be mapped to the selected plugin parameter.

 

 

Actual results:

Pressed button is not mapped to the selected plugin parameter.

However, the MIDI-Monitor of Renoise shows the MIDI message of the pressed button (independently from the checkbox "Pass unhandled MIDI messages to Renoise").

 

 

My current workaround:

 

I use Duplex to connect my controller. I make a second connection via Jack (or alternatively via Renoise Preferences/MIDI/In device X: my controller). Now I can also use the "MIDI MAPPING" of Renoise to map buttons. But than a button used by Duplex also triggers a sample sound of the currently selected instrument. So it's not really a useful workaround (especially as I would need to use Renoise+Duplex for live performance).

 

 

Any suggestion/idea is welcome!

 

 

cheers,

jrod


Edited by jrod420, 26 February 2017 - 13:52.


#2 danoise

danoise

    Probably More God or Borg Than Human Member

  • Renoise Team
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6490 posts
  • Gender:Male
  • Location:Berlin
  • Interests:wildlife + urban trekking

Posted 08 May 2017 - 17:38

Thanks for reporting - I've created a ticket on github 


Tracking with Stuff. API wishlist | Soundcloud


#3 danoise

danoise

    Probably More God or Borg Than Human Member

  • Renoise Team
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6490 posts
  • Gender:Male
  • Location:Berlin
  • Interests:wildlife + urban trekking

Posted 09 May 2017 - 21:24

I just tried, but wasn't able to recreate this issue here.

 

I wonder if you have enabled the OSC server in Renoise? The ability to create native MIDI messages from a tool relies on that component.

Unfortunately, Duplex doesn't currently check if the server is running - right now it just displays an instruction *once* - but I know how easily those gets dismissed. 

 

Edit: there's a new version (v1.02) which tries to detect if the server is running. Give this release a try?


Edited by danoise, 10 May 2017 - 19:31.

Tracking with Stuff. API wishlist | Soundcloud


#4 jrod420

jrod420

    New Member

  • Normal Members
  • Pip
  • 8 posts

Posted 17 November 2017 - 17:25

Sorry for long inactivity.

 

Indeed, I didn't realize that I have to activate the OSC server in the Renoise preferences.

I activated the OSC server and installed the most current stable version of Duplex (v.1.05).

Now unhandled midi messages are successfully passed to Renoise.

 

However, I still had the problem, when pressing a button on the midi controller, not only Duplex responded, but also a note in Renoise was triggered. The solution was to disable the midi-controller in the Renoise preferences (Edit -> Preferences -> Midi -> In device C: None).

 

Now everything works for me and I can start making noise  :badteethslayer:  Thanks for your support!  :walkman:


Edited by jrod420, 17 November 2017 - 17:28.

  • danoise and Neurogami like this





Also tagged with one or more of these keywords: DUPLEX, Pass unhandled MIDI messages, Issue, Does not work