Jump to content


Photo

MIDI INPUT PER INSTRUMENT

MIDI

  • Please log in to reply
4 replies to this topic

#1 PavelTarsovsky

PavelTarsovsky

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 19 March 2017 - 16:23

Hello everyone, 

 

maybe this question has been discussed here already but I did not find it. If yes, please send me a link. 

 

My problem. I have AKAI MPK MINI and I would like to use it the same way as computer keyboard in Renoise. That is, the MPK should control (automatically) only the instrument I select in the upper right corner. IE only the selected instrument should receive MIDI signal. It is very inconvenient that after I select another instrument in the corner the MPK is sending notes to all other instruments at the same time. Of course I know that I can assign "manually" the MIDI input device to each instrument but this is really time consuming and counter intuitive. It seems really unnatural that I have to click on 10 buttons before the MIDI keybord works the same way as computer keyboard. 

 

Maybe if there is some mod to Renoise or some tweak I did not yet discovered? 

 

Thank you very much for answers, 

 

Pavel



#2 OopsIFly

OopsIFly

    Guruh Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 814 posts
  • Gender:Male
  • Interests:...daydreams... -VS- ...propaganda...

Posted 19 March 2017 - 19:55

Yes there is some "tweak". Or rather intended standard behaviour.

 

Remove all midi mappings to the midi instrument you wish to use that way. Yes, remove. Then make sure it is in one of the 4 boxes where you can choose midi devices in the preferences.

 

It should then trigger the currently selected instrument in the currently selected track, just like the typewriter will. Track output routings will be respected. If you put the instrument in the midi tab of some instrument this behaviour will break in favor to the device now following the routings.

 

Midi mappings for parameters etc. are a bit more complex, but triggering notes, pressure, pitchbend and mod work this way.

 

HTH.


  • Neurogami likes this

#3 PavelTarsovsky

PavelTarsovsky

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 20 March 2017 - 21:18

Thank you, it worked the way you suggested. 

 

For those who are looking for the solution to this problem, do the following: 

 

1) go to edit, preferences, midi and select only one (your) MIDi device

2) click on the desired instrument in the upper right corner

3) while the instrument is selected, click on the MIDI tab on the left upper corner

4) click on "show routing overview" and then on "clear all"

 

And it is done!!!!:-))))

 

Pavel



#4 OopsIFly

OopsIFly

    Guruh Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 814 posts
  • Gender:Male
  • Interests:...daydreams... -VS- ...propaganda...

Posted 20 March 2017 - 22:00

Yes, glad I could help. And sorry for not writing it clear enough to understand right away.

 

The essence is, renoise will allow you to use a "master keyboard" set in the preferences like the pc keyboard. But it may not be associated to a certain instrument, as well as the instruments you wish to use this way must have blank midi mappings. Hence the step of clearing the mappings to make it work, you could also set/unset mappings in a more customised way if you have multiple midi devices for different tasks, but still want to use a keyboard as "on the fly" master controller.


Edited by OopsIFly, 20 March 2017 - 22:00.


#5 PavelTarsovsky

PavelTarsovsky

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 21 March 2017 - 10:05

Great, thank you. I will for sure have other questions soon:-)







Also tagged with one or more of these keywords: MIDI