Jump to content


Photo

Some XRNI only working on computer keyboard, not on midi keyboard


  • Please log in to reply
3 replies to this topic

#1 autoaim.cfg

autoaim.cfg

    Member

  • Normal Members
  • PipPip
  • 17 posts

Posted 28 March 2017 - 14:41

I'm having an infuriating problem with http://forum.renoise...-type-a-sounds/

 

It's three XRNI's -- Carbon, Harmor and Photone.

 

Carbon and Photone play ok on my computer keyboard, i.w. QWERTY. But doesn't make any sound when I'm playing on either of my midi keyboards.

 

Harmor doesn't make any sound on either one. The instrument is there and when I press return I can audit the individual samples, but nothing plays on either computer keyboard or midi keyboards.

 

All other XRNI's that I have work just fine on both. I've been trying out pretty much everything I got, but it's just that linked download that refuses to behave. Everything else I load up works just fine on the computer keyboard and both of my midi keyboards.

 

Is there some setting I've completely overlooked here or is the instrument itself broken?? Sorry if I posted a real dumb question here, but I've just stared at all the settings for an hour and I can't seem to find anything that would cause this behaviour. I've narrowed it down to three options: #1: I'm suffering from selective blindness and can't spot the correct setting. #2: The problem is something self-evident and I'm just too dumb to use XRNI's. #3: The XRNI's in question are broken in some way.

 

Any helpful thoughts?  :blink:

 

 



#2 joule

joule

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1520 posts
  • Gender:Not Telling
  • Location:Sweden
  • Interests:music, philosophy, engineering

Posted 28 March 2017 - 15:38

Just as I suspected. If you look under keyzones, the samples are only triggered if maximum velocity is used (like qwerty in default mode).

 

Option 1) Edit the keyzone by dragging the keyzones (downwards) to cover all velocities.

Option 2) Hammer your midi keyboard really, really hard when playing!



#3 OopsIFly

OopsIFly

    Guruh Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 970 posts
  • Gender:Male
  • Interests:...daydreams... -VS- ...propaganda...

Posted 28 March 2017 - 16:19

you can also disable velocity in the preferences ("midi->record & play filter"). Then your midi keyboard notes will be registered with max velocity for every hit, just like with the pc keyboard.



#4 autoaim.cfg

autoaim.cfg

    Member

  • Normal Members
  • PipPip
  • 17 posts

Posted 28 March 2017 - 19:14

Ahhhhhh.... Thanks! 

 

I covered all the velocities in the keyzone and that fixed Carbon and Photone. Works like a charm.

 

 

I still didn't get any sound out of Harmor after editing the keyzones, though... but after some more fiddling with it I found the problem in the effects chain.

 

The first effect in the effects chain is an Analog Filter that's got the cutoff set to zero... so the instrument is mute. Raised the cutoff and it works. 

 

I even downloaded Harmor again to double check that it was, in fact, the default setting of the instrument and yeah, it was.

 

Thanks for the help!  :walkman: