Jump to content


Photo

Bunch of VST guis do not open in Sierra 10.12.4


  • Please log in to reply
12 replies to this topic

#1 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 24 April 2017 - 13:38

Hi,

 

found over time a bunch of plugins, that do not open the vst gui, if you click on GUI button. This seems to be introduced since Sierra and Renoise only, so those plugins usually still work in other DAWs. That's why I assume it's a Renoise problem which is missing some adjustment for Sierra.

 

Here some examples: Loudmax , Nomad lot of plugins, Rayspace, Kazrog...

 

 

 

If you already do some macOS specific fixing, here some more suggestions:

 

- would be very nice, if Renoise would keep the file tags intact, while file overwriting

 

- File open requester poped up while playing will result in incremental cpu overload. Some Thread needs some signal or the file requester should be exclusive? No idea :)

 

- After clicking a file to load, the file request still stays open while the whole loading process. This was introduced with OSX 10.8

 

Thanks

 


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#2 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 25 April 2017 - 12:03

Oh, and:

 

Korg Polysix VST (error while loading, work around: first load AU, then load VST, then often it does not open the GUI, but is loaded)


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#3 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 25 April 2017 - 12:32

Maybe Renoise just needs to be recompiled using the recent Xcode?  And I personally think, a targeting below 10.9 is not required anymore?


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#4 grape_ape

grape_ape

    Member

  • Normal Members
  • PipPip
  • 52 posts

Posted 01 May 2017 - 18:35

I posted what appears to be the same problem: http://forum.renoise...working-though/

 

AUs work okay though, which you seem to have figured out also.


  • ffx likes this

#5 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 01 May 2017 - 19:04

I posted what appears to be the same problem: http://forum.renoise...working-though/

 

AUs work okay though, which you seem to have figured out also.

 

 

Totally forgot about that! Thanks.

 

Please join those topics!


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#6 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 18 May 2017 - 17:01

Recent waves waveshell doesnt work anymore correctly / isnt detected correctly.  You always have to start a plugin rescan so the outdated waveshell version will be replaced with the recent one. But after a DAW restart, it the same problem returns again.


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#7 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 18 May 2017 - 22:42

EDIT: There is now one waveshell only, not two anymore. Test with manual scan, not scanning on daw load. 

 

A fix for the waveshell problem is (using a sqllite editor):

UPDATE CachedPlugins SET LocalFilePath = replace( LocalFilePath, 'WaveShell-VST 9.3', 'WaveShell-VST 9.91' ) WHERE LocalFilePath LIKE '%waveshell%';
UPDATE CachedPlugins SET LocalFilePath = replace( LocalFilePath, 'WaveShell-VST 9.61', 'WaveShell-VST 9.91' ) WHERE LocalFilePath LIKE '%waveshell%';

Edited by ffx, 19 May 2017 - 00:43.

MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#8 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 19 May 2017 - 21:57

Guys, can you maybe publish an intermediate bugfix release? How can we work with such bugs (after running the AU before):

Bildschirmfoto 2017-05-19 um 22.52.30.PNG

 

Same plugin in BW2.1, same system, same interface (VST2):

Bildschirmfoto 2017-05-19 um 22.55.49.PNG

 

 


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#9 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 22 May 2017 - 13:11

The above problem actually are two problems: The "disappearing gui" is related to that plist entry "CGDisableCoalescedUpdates = true". But that entry is essential to me to make the gui not causing stutters (because of that known GUI concept weakness). So it is a little dilemma now.

 

But the second problem is that those plugins do not load at first try anymore. Either you have to load the au version first, or sometimes the vst version.

 

PLEASE FIX! 

 

Time moves on, OSes will change a bit over time, and so a complex software like Renoise needs to adapt a bit over time. And you know this. If you need help for bugtesting, please contact me.

 

Can you do a little OS update intermediate fix release at least?


Edited by ffx, 22 May 2017 - 13:13.

MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#10 Robbie S

Robbie S

    Big Super Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPip
  • 630 posts
  • Gender:Male
  • Location:• You are here
  • Interests:robbieshirts.com

Posted 23 May 2017 - 13:19

Ah! I have the same issues with the Korg Legacy Collection. Although, I can open them separately by clicking the icons in Finder. Then they start just fine, it's only in Renoise they won't start.

 

Ok, just tried and by loading the AU first then the VST works.

 

Using: OSX Sierra 10.12.5 & Renoise 3.1.0



#11 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 23 May 2017 - 14:12

Yes, it also loads just normal in the other DAWs. It obviously is a Renoise's problem.


MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#12 ffx

ffx

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2899 posts
  • Gender:Not Telling
  • Interests:Renoise sidechaining, macOS fanboying

Posted 07 June 2017 - 13:01

Found now a less annoying workaround:

 

- I put all plugins (AU versions) which require twice loading into the Renoise Template Song, so there will appear an error on start, but it will ensure all projects will load more or less normally

 

- I usually now kill hanging Renoise Plugin Hosts and quit Renoise using the terminal command

killall -m Renoise

Edited by ffx, 07 June 2017 - 13:01.

MacOS 10.12.6 Retina, Renoise 3.1 64 bit   -   Tuned Shortcuts | Multi-Jump From/To Send | Quick Template | Insert Native DSP Menu (incl. deprecated)


#13 Robbie S

Robbie S

    Big Super Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPip
  • 630 posts
  • Gender:Male
  • Location:• You are here
  • Interests:robbieshirts.com

Posted 08 September 2017 - 15:08

Hey, how is this bug going? Any fix coming?