Jump to content


Photo

Infinite song loading

bug help

  • Please log in to reply
2 replies to this topic

#1 czyrztof

czyrztof

    New Member

  • Normal Members
  • Pip
  • 6 posts

Posted 15 May 2017 - 14:08

Hey guys, i don't know why but my one project is not working, its loading infinitely, also i had couple of copies of it and none of it works. Also other projects are opening normally, any ideas how to fix it?

 

Windows 10, newest update


Edited by czyrztof, 15 May 2017 - 14:09.


#2 U4iC

U4iC

    Advanced Member

  • Normal Members
  • PipPipPip
  • 73 posts
  • Gender:Male

Posted 16 May 2017 - 19:42

Possibly using a VST in it that is borked? Removing the VST may help if that's the case. I've never had an issue with my songs corrupting besides issues with VST's.

 

Is there a possibility you ran out of memory initially saving the song? This can lead to corruption, and most likely not an easy or even possible fix.

 

Don't forget the .xrns files are also .zip files - so you can dive through and make sure all the samples are still working in the bundle, also that the .xml files are not corrupted.



#3 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5627 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 16 May 2017 - 20:02

If you're using any VST plugins that'd definitely be a good place to start looking.

Maybe one of your plugins is not registered or installed correctly, and is doing something weird when Renoise tries to scan/load it.

Some plugins may pop open a nag screen or dialog box when they're not supposed to, and that window may get stuck open somewhere hidden or behind Renoise itself, basically locking the entire application until you click 'Ok' or whatever it is.

Next time it happens see if you can Alt+Tab to some other window, or open Task Manager and see if there's anything weird going on.





Also tagged with one or more of these keywords: bug, help