Jump to content


Photo

Controlling a hardware synth with Renoise - pan/delay ignored?


  • Please log in to reply
2 replies to this topic

#1 Dex

Dex

    Member

  • Normal Members
  • PipPip
  • 14 posts

Posted 05 July 2017 - 05:42

I'm trying to use Renoise to control a hardware synth. I think I have it set up correctly - I create an instrument for my synth and select the synth as the MIDI output device for that instrument, in this case instrument 0D.

 

I write some notes in the pattern editor and hit play. q1.png

 

I hear the differences in the note velocities, but the pan and delay columns seem to have no effect. I can understand pan not having an effect (I don't think MIDI allows for pan commands), but I thought putting an entry in the delay column would delay Renoise sending the MIDI command to the synth. Apparently I am wrong. q2.png

 

Notice that both notes on each line (the note with 0 delay and the note with 80 delay) are both sent to the synth at exactly the same time. Why is this? Is there anything that can be done to make this work the way I had expected (other than increasing the LPB), and what other "gotchas" about working with hardware synths can I expect? (I'm used to how VST's function in Renoise now, but am new to controlling hardware synths with it.)



#2 4Tey

4Tey

    Chief Above Chief Member

  • Normal Members
  • PipPipPipPipPipPip
  • 382 posts
  • Gender:Male

Posted 05 July 2017 - 06:18

Dex: have a read through this thread -> Sanity check - delay methods (column vs Qxx) on midi vs sample


  • Dex likes this

#3 Dex

Dex

    Member

  • Normal Members
  • PipPip
  • 14 posts

Posted 05 July 2017 - 06:51

Dex: have a read through this thread -> Sanity check - delay methods (column vs Qxx) on midi vs sample

Thank you!

 

I'm on Renoise 3.1 and don't have access to an earlier version, so what worked for me was turning on phrases in the midi instrument, creating a phrase, and setting the phrase control for the instrument to "Prg." The Delay column now functions as expected. Weird workaround, but I'll take it!