Jump to content


Photo

Linux midi out help - skips


  • Please log in to reply
3 replies to this topic

#1 infinite-kevins

infinite-kevins

    New Member

  • Normal Members
  • Pip
  • 2 posts

Posted 20 July 2017 - 01:28

Hi all

 

I've recently migrated to Linux and Renoise. Loving the Renoise workflow!

 

But I have just noticed that I am unable to send out a steady midi sequence to my hardware synths.

A simple 8th note sequence sent out of my USB soundcard midi skips and cannot play back steadily.

 

I'm using Jack with Alsa midi. Buffer size is set high, but makes no difference.

 

Any Linux guru's here have any suggestions?

 



#2 niNja_pWn3d

niNja_pWn3d

    Big GrandDaddy Member

  • Normal Members
  • PipPipPipPipPipPipPipPip
  • 452 posts
  • Gender:Male
  • Location:Tha' 204!
  • Interests:..:: My kids - Music - Production - Promotion - 8bit - amen - Hax0r ::..

Posted 21 July 2017 - 02:50

what do you mean 'hardware' synths? Like euro? just a straight up synth? 

 

cheers!


Youtube!
Soundcloud!

"The magnitude of pleasure reaches its limit in the removal of all pain. When such pleasure is present, so long as it is uninterrupted, there is no pain either of body or of mind or of both together." -Epicurus

#3 infinite-kevins

infinite-kevins

    New Member

  • Normal Members
  • Pip
  • 2 posts

Posted 21 July 2017 - 03:07

Both actually, but I'm not sure how that matters?



#4 rutsch

rutsch

    New Member

  • Normal Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Germany

Posted 21 July 2017 - 12:10

If you use Jack you need a Jack Midi to Alsa bridge like a2jmidid.

To use your hardware Midi outs run a2jmidid with the -e option.

Check this: http://manual.ardour.../midi-on-linux/

 

You can automatically start and stop a2jmidi with qjackctl on the Option tab:

Script after start: a2jmidid -e &

Script after stop: killall a2jmidid &


Edited by rutsch, 21 July 2017 - 12:14.