Jump to content


Photo

Akai APC Mini in Renoise/Duplex

Akai APC Mini Duplex

  • Please log in to reply
1 reply to this topic

#1 Psychometric

Psychometric

    New Member

  • Normal Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Glasgow, Scotland
  • Interests:Music, Gaming, Art, Design, Creating things

Posted 16 September 2017 - 17:49

Hi there

 

Apologies if this isn't the best place for this post, but the other topic that I found seems to have died and isn't getting much attention.

 

I recently picked up an Akai APC Mini and I want to use it with Renoise as part of a live setup.

 

It seems like it would be a great controller for Duplex/Gridpie but for whatever reason there's never been a full layout made for it.

 

I'm picking up where this topic left off: http://forum.renoise...ini-controller/

 

The files in that post work and allow me to use the mixer on the device as well as some buttons for muting tracks (along with the code added in a post further down which allows the LEDs to switch back off).

 

Using that as a basis, I've tried to make a GridPie layout, with limited success. I've mapped the 8x8 grid of buttons, and have successfully used the device to trigger patterns, however I'm struggling to get my head around the colorspace functions, so patterns that are not empty but not playing are not lighting up on the device making it a bit hard to use.

 

Also I seem to have broke the mixer while adding the rest of this stuff and I'm struggling to see how as I didn't change that code... EDIT: Fixed this, I had capitalized Mappings when it should have been lower case it seems...

 

I'll attach the files I've made (keep in mind this is all work in progress stuff, probably full of incorrect code, as I'm basically attempting to patch this together from looking at the other layouts that come with it, and I'm not super familiar with LUA).

 

If anyone has any idea what they're doing with this stuff I'd appreciate any help. I'd really like to get this working if possible.

 

Its seems like the actual functions are working, but the device isn't lighting up the right way and I don't know enough about how colorspace is handled to fix it.

 

Also if this is the wrong place to put this, apologies, if you can direct me to somewhere appropriate (preferably somewhere appropriate that actually gets looked at) that would be appreciated.

 

EDIT: Apparently I also misspelled 'palette'... fixed, not that it really affected much.

Attached Files


Edited by Psychometric, 16 September 2017 - 21:07.


#2 Psychometric

Psychometric

    New Member

  • Normal Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Glasgow, Scotland
  • Interests:Music, Gaming, Art, Design, Creating things

Posted 16 September 2017 - 18:16

Right, got the mixer working again, apparently LUA is case sensitive  :blush:

 

 

EDIT: Didn't want to make a new post as I've kinda double posted already.

 

Made some progress after looking up some documentation on GitHub. Managed to get the device to light up as it should. I've currently got yellow LEDs for unselected but not empty patterns, green for selected patterns, and red highlighting the selected track (may or may not keep this as not sure if it's going to be useful, just wanted to test the red colour).

 

Seems to be working as expected so far. 

 

I'm going to look at integrating some kind of grid navigation controls next, and something else with the remaining buttons (loopers possibly if I can work it out).

 

I'll have a look at the GridPie documentation and see what I can work out. In the meantime, I've attached the updated files.

 

 

 

 

 

 

 

 

 

EDIT: 

 

Didn't want to turn this into a triple post so I've edited this post again.

 

I've integrated pattern navigation controls onto the arrow buttons so it's now possible to move around the sequence and tracks. 

 

I've also added a 'Navigator' application to the right hand column of buttons, the readme suggested it has some looping capabilities, however so far this isn't working quite like I expected it to so perhaps I'm misunderstanding it. The button colours in the Navigator part seem to also not be following the palette I set for some reason that I'm not yet sure of.

 

I've set up a GitHub repository for all this rather than continually posting attachments on the forums. 

 

https://github.com/K...duplex-apc-mini

Attached Files


Edited by Psychometric, 17 September 2017 - 13:42.






Also tagged with one or more of these keywords: Akai, APC Mini, Duplex