Jump to content


Photo

Solo State Bug in the Lua API?


  • Please log in to reply
2 replies to this topic

#1 Ledger

Ledger

    Guruh Motha Fakka Knows More About Renoise Than Taktik

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3401 posts
  • Gender:Male

Posted 12 November 2017 - 17:20

The following snippet first solos `Track 01 ` then manually unmutes all other tracks. Now all tracks are playing and `Track 01 ` is no longer solo.

 

However when you print the solo state of  `Track 01 `, it reports the solo state still as true:

local song = renoise.song()
--1)set solo state  of track 1 to true
song.tracks[1].solo_state = true

--print solo state of track 1
print(song.tracks[1].solo_state)

--2) manually set all tracks to unmuted
for track = 1,#song.tracks do
 song:track(track).mute_state = renoise.Track.MUTE_STATE_ACTIVE
end

--print solo state of track 1 
--SHOULD BE FALSE BUT PRINTS TRUE??
print(song.tracks[1].solo_state)

Edited by Ledger, 12 November 2017 - 17:21.

--> Lua For Beginners <--
--> Lua for newbies <--

My Scripts On Forum

Top Tip!

 

cpu : Xeon 1231 v3, os : Win 7 64bit, audio: Audient iD4
posts as 4tune @ KvR and some other music related sites


#2 joule

joule

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1502 posts
  • Gender:Not Telling
  • Location:Sweden
  • Interests:music, philosophy, engineering

Posted 12 November 2017 - 18:52

Sounds like a bug to me. Solo and mute should be two separate things - always.

 

(Maybe it's is a special case when all tracks are unmuted that goes bananas? Perhaps a bug inherited from the practicality of how the UI works)

 

Could it be that the mute state simply has a higher "priority" than the solo state?


Edited by joule, 12 November 2017 - 18:54.


#3 Ledger

Ledger

    Guruh Motha Fakka Knows More About Renoise Than Taktik

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3401 posts
  • Gender:Male

Posted 12 November 2017 - 19:21

I guess it is that the solo property is not updated as other tracks are un-muted.  Only devs will know though..


--> Lua For Beginners <--
--> Lua for newbies <--

My Scripts On Forum

Top Tip!

 

cpu : Xeon 1231 v3, os : Win 7 64bit, audio: Audient iD4
posts as 4tune @ KvR and some other music related sites