Jump to content


Photo

Renoise "Reverb" device different results on rendering w/ diff


  • Please log in to reply
4 replies to this topic

#1 OopsIFly

OopsIFly

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1024 posts
  • Gender:Male
  • Location:Meist völlig betrunken in der Hofnarrenkammer
  • Interests:Lavalampen stundenlang anglotzen

Posted 12 January 2018 - 01:13

Renoise 3.1.1 on Linux

 

As the title suggests, I have sounds that drastically change their charakter when rendered at different rates.

 

I was designing instruments in a series, where the bassdrum is featuring layering with some kind of heavy bass/sub reverb action, all balanced out nicely, while working @ 44.1 khz. I used the renoise "Reverb" device for generating the reverb as it had shown the best (most organic) results in the bass frequencies.

 

But when I rendered the instruments at a higher rate, they suddenly sounded very different, a lot of the reverb in the lower bass frequencies suddenly seems to get cut out, leading to the bassdrums sometimes just sounding "cleaner" than expected - but in instruments where I do sound design based on distorting reverbs of bass frequencies, the difference was so big that the sounds did not sound similar enough to still work in the mix.

 

Rendering at 44.1 sounds the same as I am working on, the renoise mpreverb device works as expected.

 

I can supply an example track with 2 versions of bassdrums using each reverb device, that produces different renders at 44.1 and 192k if you like.

 

Is there any hope to have it fixed somehow, or should I go through all my files and replace all the reverbs? I certainly wish to render my stuff at 192k.



#2 OopsIFly

OopsIFly

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1024 posts
  • Gender:Male
  • Location:Meist völlig betrunken in der Hofnarrenkammer
  • Interests:Lavalampen stundenlang anglotzen

Posted 17 January 2018 - 19:15

No feedback on this yet? It really seems like with high rates the (sub)bass response of the reverb device is lacking compared to low rates. I think it could be matter of some DC/Hipass filter in the device not adjusting itself, or in the wrong direction, depending on sample rate? Or is the whole algo fixed to a single rate - then you should consider choosing a rate, and just resampling the beast for all other rates. Broken renders are a showstopper! It made a dark cavernous rumble sound turn into weak wet farts, not the intended sound I had in mind and ears while constructing it... ;-)

 

For the record, the projects that use the reverb and that sound too different when rendered in hi res, I decided to use this technique in: http://forum.renoise...ins-in-renoise/

 

First tests seem it sounds a lot like the original device, though it takes 2x-4x the cpu power. Also it destroys the algorithmic (nonlinear) quality of the reverb making it sound less organic, the same reaction with the same sound all the time instead, though it is less worse then I first feared.



#3 realist

realist

    Composes without Wires burns Directly from Brain to DVD that is already in Store Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3093 posts
  • Gender:Not Telling

Posted 17 January 2018 - 19:47

.

Edited by realist, 17 January 2018 - 19:53.

.

#4 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5685 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 17 January 2018 - 19:48

I took a quick look and unfortunately it does appear that the Reverb device was originally hand-tuned to work at 44.1kHz only, so it currently does not scale very gracefully (at all) to higher sample rates.

We'll obviously have to try and take a look at fixing this at some point in the future.
  • OopsIFly and El°HYM like this

#5 El°HYM

El°HYM

    Advanced Member

  • Normal Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:NIBIRU
  • Interests:I AM El°HYM

Posted 18 January 2018 - 18:56

Now you see what happens, if randomly updated without a reason, I mean Renoise!...Just sayin'  :walkman:

 

2.7.2 FtW.