Jump to content


Photo

Rewire: A real tutorial

rewire lmms tracker vst ladspa

  • Please log in to reply
3 replies to this topic

#1 shadowzero26

shadowzero26

    New Member

  • Normal Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Detroit
  • Interests:Shoegaze, dark synth, 80's, classic rock, chip, classic techno, acid, late 90's trance, alt, western, classic hip-hop, rock n' roll, anything with "wave" in the name, futurepop is too broad.

Posted 18 January 2018 - 05:20

Hello guys and gals.  I've been using Renoise since late November and I adore it.  It is just about perfect. 

 

How can I get Rewire to work?  I can't get it to work at all.  I can't get it to work with Pro Tools, I can't get Renoise to receive audio from LMMS, I can't get it to work with any other trackers and I don't know if it's even possible.  I know people have trouble with Pro Tools, but the solutions may or may not work because I can't get anything to show up in Renoise.

 

I tried starting things in different orders.  I can't figure out if I need to load a plugin in LMMS, or something... maybe output to something specific.... The tutorial just says,

FROM : http://tutorials.ren...ire&oldid=1310 
"In the “#ReWire-In Device” will be a drop-down with a list of installed slaves. Select one. In most cases the slave will automatically launch. If not, then launch the application manually."

 

Launch the application manually?  What does that mean? It just says "none."  I thought I was supposed to have it open already.  Maybe it only works with specific devices and I just don't have any of them, but I'm not the only one that seems to have this problem.  

 

I'm on a Windows 10 and would like to use Renoise with LMMS and any other trackers like Famitracker and Milkytracker if possible.  Protools would be nice, since some people have success with that, but I don't currently see the advantage for my habits.

 

What are the specific steps to getting rewire to work either with renoise as slave or master?

 

If I'm just dumb and should stick to bouncing audio and loading it as samples in Renoise just let me know.  Thank you for your time.



#2 Neurogami

Neurogami

    Big Super Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPip
  • 682 posts
  • Gender:Male
  • Location:Scottsdale AZ
  • Interests:Art, music, technology

Posted 18 January 2018 - 06:30

Are you running 32-bit or 64-bit Renoise?  What about the other apps?  32 or 64? I believe the need to be the same for all Rewire participants.



#3 shadowzero26

shadowzero26

    New Member

  • Normal Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Detroit
  • Interests:Shoegaze, dark synth, 80's, classic rock, chip, classic techno, acid, late 90's trance, alt, western, classic hip-hop, rock n' roll, anything with "wave" in the name, futurepop is too broad.

Posted 18 January 2018 - 07:08

Are you running 32-bit or 64-bit Renoise?  What about the other apps?  32 or 64? I believe the need to be the same for all Rewire participants.

I'm pretty sure I'm running 64-bit lmms. My version of pro tools is weird.  I don't think it is technically 64 bit.



#4 m.arthur

m.arthur

    Advanced Member

  • Normal Members
  • PipPipPip
  • 112 posts
  • Gender:Male
  • Location:Portland, Oregon
  • Interests:EBM, IDM, industrial, radiophonic & beyond

Posted 18 January 2018 - 20:51

I'm pretty sure I'm running 64-bit lmms. My version of pro tools is weird.  I don't think it is technically 64 bit.

 

Well that, right there, is your problem.

 

Rewire requires both programs to run at the same settings, 32 or 64. They can't be different.


old-school industrial music:  dead when i found her

 






Also tagged with one or more of these keywords: rewire, lmms, tracker, vst, ladspa