Jump to content


Photo

trouble after installation (Linux)


  • Please log in to reply
7 replies to this topic

#1 ZoaZ

ZoaZ

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 02 February 2018 - 21:52

Hello! I' m brand new here and I need help already, please. I bought  Renoise 3.1! The installation succeeded but I can't launch the program, I get a message saying -pardon me french-
'bash: /usr/local/bin/renoise : impossible d’exécuter le fichier binaire : Erreur de format pour exec()'
which would perhaps translate to 'cannot execute binary file; format error for exec()' ?
I tried a different version (2.8 - DOA) prior to this, so I'm suspecting maybe this is why 3.1 doesn't start?
2.8 works fine on this computer (Pentium IV 3GHz!), I'm pretty new to Linux (Lubuntu Xenial Xerus) but I have Alsa and Jack and all that sorted: this should work.
What should I do?



#2 El°HYM

El°HYM

    Big Super GrandMasta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 761 posts
  • Gender:Male
  • Location:NIBIRU
  • Interests:I AM El°HYM

Posted 02 February 2018 - 22:06

Actually 2.8 is the best version, imo

 

...other than that there are some #linux users, who can surely help.

 

Welcome!


  • lilith likes this

Inside ur Renoise; helping Byte-Smasher putting Cab Sims on ur Master.  :ph34r: 


#3 lilith

lilith

    Advanced Member

  • Normal Members
  • PipPipPip
  • 87 posts
  • Gender:Male
  • Location:Germany - Karlsruhe

Posted 02 February 2018 - 23:17

How did you launch the program? Can you go into your /home directory and look for renoise there? Double Click renoise file... what happens?



#4 ZoaZ

ZoaZ

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 03 February 2018 - 16:49

Thanks guys! I've tried launching Renoise via start menu, via terminal, and I've also tried double clicking the executable inside ~/rns_3_1_1_linux_x86_64. It's the same result everytime, It doesn't start.


What's wrong with Renoise latest versions?

 

Actually 2.8 is the best version, imo

 

...other than that there are some #linux users, who can surely help.

 

Welcome!



#5 lilith

lilith

    Advanced Member

  • Normal Members
  • PipPipPip
  • 87 posts
  • Gender:Male
  • Location:Germany - Karlsruhe

Posted 03 February 2018 - 17:38

Does your CPU support 64 bit? Did you try the 32 bit version too?

Edited by lilith, 03 February 2018 - 17:39.


#6 ZoaZ

ZoaZ

    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 03 February 2018 - 17:56

Doh. I thought I dowloaded the 32 bits version but now that I'm downloading again, I see I had that wrong. Many thanks for pointing this out!



#7 lilith

lilith

    Advanced Member

  • Normal Members
  • PipPipPip
  • 87 posts
  • Gender:Male
  • Location:Germany - Karlsruhe

Posted 03 February 2018 - 18:45

Actually 2.8 is the best version, imo

...other than that there are some #linux users, who can surely help.

Welcome!


Why do you favor 2.8 over 3.1 ?

#8 El°HYM

El°HYM

    Big Super GrandMasta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 761 posts
  • Gender:Male
  • Location:NIBIRU
  • Interests:I AM El°HYM

Posted 03 February 2018 - 22:48

Why do you favor 2.8 over 3.1 ?

 

There are some toolz & scripts that only work with 2.8.2 & this is the last version which handles old #vsts properly, like 32bit, synthedit ones & doesnt eat up the cpu while doing so...so it more personal preferences (imo) not saying the newer versions are bad at all, its just my personal choice & workflow, me likes more.


Edited by El°HYM, 03 February 2018 - 22:49.

Inside ur Renoise; helping Byte-Smasher putting Cab Sims on ur Master.  :ph34r: