Jump to content


Photo

"Render song to disk" doesn't seem to handle plugin automa


  • Please log in to reply
1 reply to this topic

#1 pat

pat

    Big Masta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPip
  • 505 posts
  • Gender:Male

Posted 07 February 2018 - 00:32

Okay this is probably pretty uncommon... but I'm trying out "cytomic the drop" filter plugin, and noticed a weird difference in how "render song to disk" handles automation vs "render to sample."

 

If you enable "follow player position in pattern", do a filter sweep, select master in the pattern editor, and "render to sample" starting from line 1 then it produces what you'd expect – a filter sweep starting at the beginning frequency. If you choose "Render song to disk" though, you get a really fast filter sweep at the beginning before it goes into the automated filter sweep. It's very similar to if you disable "follow player position", stop playback in the middle of the filter sweep, and start playback from the beginning. You hear the plugin moving from its most recent frequency to the start of the automation sweep.

 

This only occurs when "auto suspend plugin when silent" is enabled. So it's easy to bypass, just disable that option. Though for a CPU-heavy plugin like The Drop, it would be nice to be able to enable that option.

 

It seems as though "render to sample" somehow informs the plugin of its starting automation value before rendering, whereas "render song to disk" does not.

 

Expected: "render to sample" and "render song to disk" produce the same result, with "auto suspend plugin when silent" enabled and there is plugin automation

Actual: "render song to disk" produces a different result, seemingly because it doesn't inform the plugin of starting automation value before rendering



#2 Jengamon

Jengamon

    New Member

  • Normal Members
  • Pip
  • 7 posts

Posted 16 February 2018 - 06:02

Did you do a realtime render? That might fix the problem.