Jump to content


Mac - .zip to .xrnl makes .xml unreadable

  • Please log in to reply
2 replies to this topic

#1 Zhu


    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 23 February 2018 - 06:03

I have been having issues with making a library .xrnl file that can properly install on my Mac. I have made a manifest.xml using TextEdit, Text Wrangler, XEdit, and other XML programs. Then I have zipped my root folder using the native compressor on my Mac, X7z, iZip, Stuffit , making it a .zip with the Samples folder and manifest.xml within it. Then I change the name to a .xrnl and turn it into it. With the manifest.xml I used com.renoise.abakus as my ID. I also named the folder that. I have made new text files and also copied Psudaform's manifest.xml. I also have an issue where I turn the psudaform.xrnl into a .zip, uncompress, recompress, rename back to the same .xrnl and it doesn't register the .xml.


I've read the instructions on the site and saw another post on the forums with similar instructions, but it says to zip the folder -inside- the root folder? Is there a way you could demonstrate the process so I can see where I went wrong?







I use a 2013 Macbook Pro, I have High Sierra installed.

Attached Images

  • Screenshot 2018-02-22 21.02.13.png
  • Screenshot 2018-02-22 21.02.32.png

Edited by Zhu, 25 February 2018 - 23:41.

#2 danoise


    Probably More God or Borg Than Human Member

  • Renoise Team
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6695 posts
  • Gender:Male
  • Location:Berlin
  • Interests:wildlife + urban trekking

Posted 23 February 2018 - 11:39

I'm guessing the zip archive was created in the wrong way. 
When creating the final zipped archive. this should be done from within the folder - meaning, you would navigate Finder into the folder, select it's contents and zip them. 
The resulting file is the library - just needs to be renamed to .xrnl before you can use it.
IOW, when opening the resulting zip file, the manifest.xml should appear in the "root" of the zipped file structure. 
From your screenshot, the library itself (the selected folder) looks good. Manifest is in the right place and all - it should just work if you copied it into the Renoise documents > Installed Libraries folder.
Can you confirm that the ".xrnl" just below has an identical file structure? 

I've read the instructions on the site

For good measure, here is the documentation link:

Tracking with Stuff. API wishlist | Soundcloud

#3 Zhu


    New Member

  • Normal Members
  • Pip
  • 3 posts

Posted 25 February 2018 - 23:39

You nailed it with my process of compressing the folder and not the 2 files together. That helps out a lot. Thank you so much for your hard work. Also thanks for continuing tool support or forum monitoring, it's been extremely useful. As well as posting new Youtube videos on Renoise, it helps out a great deal.

Edited by Zhu, 25 February 2018 - 23:42.