Jump to content


Photo

Redux 1.0.2 (Linux) not accepting Program Changes unless Redux GUI is

linux redux

  • Please log in to reply
4 replies to this topic

#1 Gavin Graham

Gavin Graham

    Advanced Member

  • Normal Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Brisbane, Australia
  • Interests:Chiptune, Bitpop, 8bit Core

Posted 28 March 2018 - 21:07

Hi,
 
I'm doing program changes in a clip and I've noticed that they aren't being invoked in the Redux VST. What is happening is that the program in the VST properties tab in Waveform 9 is being used.
 
The thing is that if I then open up the GUI for the Redux VST, THEN it will receive and change programs! Close the VST's gui and it then just plays the last program instead of listening to program change messages.
 
I'm running native plugins and Waveform under Ubuntu 17.10.
 
Tested it out under Windows 10 and it works as expected.
 
I downloaded a demo of another Linux DAW and had the same results. I then downgraded the Redux plugin to the previous version and it now works fine in Waveform 9 (and the other DAW).
 
Cheers,
Gavin

Me on Soundcloud: My link

#2 mikobuntu

mikobuntu

    Advanced Member

  • Normal Members
  • PipPipPip
  • 73 posts

Posted 07 September 2018 - 16:08

I'm having the exact same problem on Renoise, Bitwig and Waveform-9 ( I haven't tried with any other Linux daws yet, but I expect the behavior to be similar )

I'm also using Redux-1.0.2.



#3 Gavin Graham

Gavin Graham

    Advanced Member

  • Normal Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Brisbane, Australia
  • Interests:Chiptune, Bitpop, 8bit Core

Posted 14 September 2018 - 02:54

I'm having the exact same problem on Renoise, Bitwig and Waveform-9 ( I haven't tried with any other Linux daws yet, but I expect the behavior to be similar )

I'm also using Redux-1.0.2.

 

Hey there,

 

It only affects v1.0.2. If you go back to the previous version, this works fine.


Me on Soundcloud: My link

#4 mikobuntu

mikobuntu

    Advanced Member

  • Normal Members
  • PipPipPip
  • 73 posts

Posted 14 September 2018 - 20:33

Thanks @Gavin , I might try a parallel install with the 1.0.1 version installed to a different directory, just for use in Waveform. 



#5 mikobuntu

mikobuntu

    Advanced Member

  • Normal Members
  • PipPipPip
  • 73 posts

Posted 15 September 2018 - 13:45

Great , Waveform is able to find both my versions of Redux and version 1.0.1 does indeed fix the issue, thanks :)







Also tagged with one or more of these keywords: linux, redux