Jump to content


Photo

CPU : 99.9% on my projects overnight


  • Please log in to reply
9 replies to this topic

#1 NocifLentus

NocifLentus

    Member

  • Normal Members
  • PipPip
  • 18 posts

Posted 10 May 2018 - 15:09

Hi, so this is not a specific problem to Renoise, it happens on Cubase and Traktor too but maybe somebody here will have a clue (all configuration below) and I use quite a lot of plugins on my projects but everything was fine until suddenly (literally overnight) 
I can't even load 3 plugins and the asio load is full in both softwares.

I changed the buffer size from 512 to 2048, tried to update my drivers, double checked my RAM with a memtest, I tried with an old M-audio delta soundcard, I checked for errors and made a defragmentation of my HD where I store my projects and I even try to open a new project on my SSD (where my OS and plugins are installed) and I reinstalled my DAWs and plugins but it's still the same.
And finally, I just did a format and reinstalled Windows and all the drivers... It's still the same. :unsure:  
I have to admit I'm out of ideas, if anyone has a clue of what's happening. rock.gif

Configuration : Win 7 professional x64
AMD FX 8350 eight core 4.00 GHz
Soundcard Onyx Blackbird
16Go Ram 

Cubase 5.1 (32 bits)
Renoise 3.1.0 (32 bits)

#2 Raul (ulneiz)

Raul (ulneiz)

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1343 posts
  • Gender:Male
  • Location:Spain

Posted 10 May 2018 - 15:26

On your projects overnight?

 

Does not this happen to you during the day?

 

If this is so, is it possible that the cause is that Windows 7 has some task scheduled during the night, which demands a lot of process?

 

That process of 99.99% comes from the Renoise exe? Have you checked this from the Windows task manager?

 

Windows can do scheduled tasks by default during the night. Maybe it has something to do...

 

The simplest thing is to open the task manager of Windows 7 and find out which executable is the cause of so much CPU demand.

 

It only happens to you with audio programs? Do you have a very high sampling frequency, higher than 48000?


:excl: Development of my tools PhraseTouch  |  GT16-Colors (old)

 

:excl: My API wishlist R3.1 (updated 24 July 2017):

Spoiler

 

:excl: My Renoise 3.1 wishlist (updated 26 September 2017):

Spoiler

#3 ffx

ffx

    Composes without Wires burns Directly from Brain to DVD that is already in Store Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3307 posts
  • Gender:Not Telling

Posted 10 May 2018 - 15:30

Check cpu power profile in Windows' energy options and set it to desktop/workstation.


  • Conner_Bw likes this

Test system: macOS 10.13.4, HFS+. Firewire Audio, i7 4770, 8GB Ram, GTX1050 2GB, 48kHz


#4 gentleclockdivider

gentleclockdivider

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2796 posts
  • Gender:Male
  • Location:something like a sea or a river...just moving
  • Interests:slacking

Posted 10 May 2018 - 15:50

check taskmanager to see if windows is updating in the background ..

 

Someone else mentioned the same sort of problem , might be related to spectre/meltdown .bug/update patch ..but then we would see more cpu perf. related reports on the forum  , .which is not the case 


THERE IS NO RELIGION SUPERIOR TO THE TRUTH


THERE IS NO TRUTH SUPERIOR TO THE ONE I CHOOSE

C'EST MIEUX D'ETRE BELLE ET REBELLE


QUE MOCHE ET REMOCHE



RUBIO RABIA

 


#5 NocifLentus

NocifLentus

    Member

  • Normal Members
  • PipPip
  • 18 posts

Posted 12 May 2018 - 09:22

Raul (ulneiz)
 
Overnight means from one day to another =) It's not only during night =)
It's the CPU inside Renoise and asio load in cubase that are 100% Windows task manager tells me UC is 34% and memory 50%...
I'm on 44.1kHz
 
Thank you. 
 
ffx
 
Yeah, I tried to change the cpu power in advanced parameters to 100% min and max, no change...

Edited by dblue, 12 May 2018 - 10:32.
Removed a lot of extra accidental (?) quotes and HTML


#6 danoise

danoise

    Probably More God or Borg Than Human Member

  • Renoise Team
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6795 posts
  • Gender:Male
  • Location:Berlin
  • Interests:wildlife + urban trekking

Posted 12 May 2018 - 10:40

Someone else mentioned the same sort of problem

 

That would be this topic, I think

https://forum.renois...racking-sounds/


Tracking with Stuff. API wishlist | Soundcloud


#7 dblue

dblue

    Dodgy Geezer

  • Admins
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5784 posts
  • Gender:Male
  • Location:Berlin
  • Interests:Code. Music. Graphics.

Posted 12 May 2018 - 10:42

@NocifLentus: I'm not sure if you're typing your message in an external editor like Word/OpenOffice and then copying it over to the forum, or if you're just a really big fan of BBCode, hehe, but there was quite a bunch of unnecessary HTML that somehow got included with your text, and it seemed to mess up the formatting a bit so I performed some quick clean-up. Hope you don't mind too much!

#8 NocifLentus

NocifLentus

    Member

  • Normal Members
  • PipPip
  • 18 posts

Posted 12 May 2018 - 11:16

Oh yeah, sorry for that, I think it's because I clicked "More reply options... I don't really know how that happen. 

 

Thank you very much =)


That would be this topic, I think

https://forum.renois...racking-sounds/

 

Yeah it sounds exactly like it!

 

Gonna read this fully. 

 

Thank you so much! I feel less alone! 



#9 NocifLentus

NocifLentus

    Member

  • Normal Members
  • PipPip
  • 18 posts

Posted 12 May 2018 - 12:10

Ok, I'm joining the other thread, I've tried everything suggested over there. 

Should I close this one?



#10 NocifLentus

NocifLentus

    Member

  • Normal Members
  • PipPip
  • 18 posts

Posted 13 May 2018 - 11:12

So as far as I went, I found a software that helps with knowing audio streaming capacity : 

 

http://www.resplendence.com/latencymon

 

and this thread on the microsoft forum :

 

https://answers.micr...98-48a67819472d

 

It seems this has something to do with dgxkrnl.sys and probably Nvidia 3d drivers...

 

I format and reinstalled windows a last time without the updates, everything is the same. 

 

I found that disabling CPU throtling and using 32 bit vst's with jbridge in Renoise 3.1 64 bit decreased a bit CPU usage... but I'll just remember the days when I had 30 waves audio vsts and 15 arturia synths on the same project with nostalgia...

 

I hope this can help.


  • PPLo likes this