Jump to content


Photo

Recording very short midi notes


  • Please log in to reply
7 replies to this topic

#1 realbogart

realbogart

    New Member

  • Normal Members
  • Pip
  • 4 posts

Posted 13 May 2018 - 18:15

Hey guys!

 

I am trying to record very short notes with my midi keyboard. Note offs are recorded correctly for longer notes but I can't record notes that cut before the next 16th note. It sounds correct when I record but not when playing back the recorded notes. Can this be done or is it a limitation of the midi recording in Renoise?

 

Thanks!

 

P.S. I've been using Renoise for a couple of months now and I absolutely love it! This is my first post in this forum. Cheers!



#2 Paul Buck

Paul Buck

    Advanced Member

  • Normal Members
  • PipPipPip
  • 87 posts
  • Gender:Male
  • Location:Drain

Posted 13 May 2018 - 19:07

Increase the LPB?
  • Neurogami likes this

#3 realbogart

realbogart

    New Member

  • Normal Members
  • Pip
  • 4 posts

Posted 13 May 2018 - 22:31

Increase the LPB?

 

I guess that is a solution. Thanks! For my current project I manually added cut commands to each note that was too long



#4 gentleclockdivider

gentleclockdivider

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2878 posts
  • Gender:Male
  • Location:something like a sea or a river...just moving
  • Interests:slacking

Posted 13 May 2018 - 22:37

enable note delay 


THERE IS NO RELIGION SUPERIOR TO THE TRUTH


THERE IS NO TRUTH SUPERIOR TO THE ONE I CHOOSE

C'EST MIEUX D'ETRE BELLE ET REBELLE


QUE MOCHE ET REMOCHE



RUBIO RABIA

 


#5 2 daze j

2 daze j

    Guruh Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 805 posts
  • Gender:Male
  • Interests:Ghosts, aliens, space, the afterlife, music, high energy music..

Posted 13 May 2018 - 22:38

Is your midi keyboard properly set up in preferences and midi?

 

likethis.png

 

If not properly set up, increasing LPB is likely to do nothing, notice how the A_series keyboard is connected to the instrument


Edited by 2 daze j, 13 May 2018 - 22:39.

I woke up with my mind on the floor...


#6 realbogart

realbogart

    New Member

  • Normal Members
  • Pip
  • 4 posts

Posted 14 May 2018 - 09:16

enable note delay 

 

Do you mean the DLY column? It is enabled and is being recorded. Velocities are being recorded in the VOL column



#7 realbogart

realbogart

    New Member

  • Normal Members
  • Pip
  • 4 posts

Posted 14 May 2018 - 09:26

Is your midi keyboard properly set up in preferences and midi?

 

attachicon.giflikethis.png

 

If not properly set up, increasing LPB is likely to do nothing, notice how the A_series keyboard is connected to the instrument

 

Yes, it is set up correctly and I can record stuff. Just not the short notes.

 

My guess is that renoise just record velocities and delays, and not note cut offs.



#8 gentleclockdivider

gentleclockdivider

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2878 posts
  • Gender:Male
  • Location:something like a sea or a river...just moving
  • Interests:slacking

Posted 14 May 2018 - 12:39

Yes , you need to set the note delay for the note -off manually .

 

If you're using midi out you can adjust the note length -----> instr.miditab./output device /note length.

Renoise will then automatically send a midi note-off command , altough this is not recorded in the pattern editor 


THERE IS NO RELIGION SUPERIOR TO THE TRUTH


THERE IS NO TRUTH SUPERIOR TO THE ONE I CHOOSE

C'EST MIEUX D'ETRE BELLE ET REBELLE


QUE MOCHE ET REMOCHE



RUBIO RABIA