Jump to content


Photo

macOS Mojave: Internal Error: Failed to connect to the external audio


  • Please log in to reply
5 replies to this topic

#1 esaruoho

esaruoho

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2679 posts
  • Gender:Male
  • Location:Kontula, Helsinki, Finland
  • Interests://Varying Interests//

Posted 20 June 2018 - 21:04

Hi guys, what's going on? I'm running macOS Mojave and pretty much every single (older) module I try to load crashes with Renoise 3, but with Renoise 2.8 I will, while trying to add VST plugin searching into the mix get this error:

 

Internal Error: Failed to connect to the external audio plugin process (could not establish a connection to the server).


http://lackluster.org | on Bandcamp | on YouTube | on Facebook | on Spotify | on iTunes | on TiDAL | on Soundcloud | 

http://twitter.com/esaruoho | http://esaruoho.tumblr.com | GitHubesaruoho@gmail.com | 

| macOS 10.13 High Sierra | MacBook Pro 2.8 GHz Intel Core i7 / 16 Gb 1600 MHz DDR 3 |

| http://renoise.com/tools/paketti | BTC: 1BoZ9rvb8wT7dFNyVPwSX7DLj3stNo7844 | http://paypal.me/esaruoho |

| Latent Impulse Tracker/Scream Tracker 3/Schism Tracker <-> Renoise fanatic |

More API functions, please! ;) http://forum.renoise.com/index.php/topic/26329-the-api-wishlist-thread/page-3#entry240266

#2 Guest_ffx_*

Guest_ffx_*

    Composes without Wires burns Directly from Brain to DVD that is already in Store Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3521 posts
  • Gender:Not Telling

Posted 20 June 2018 - 21:29

By "older module" you mean 32 bit plugins using Renoise bit bridge? Could be that 10.14 prevents any 32 bit execution at all, so the plugin bridge won't work. 

 

- Do 32 bit plugins still work in other DAWs?

 

- Do ist work if you only load 64 bit plugins?

 

- What happens if you disable sandboxing in the settings (and then restart renoise)?



#3 esaruoho

esaruoho

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2679 posts
  • Gender:Male
  • Location:Kontula, Helsinki, Finland
  • Interests://Varying Interests//

Posted 20 June 2018 - 21:55

By "older module" you mean 32 bit plugins using Renoise bit bridge? Could be that 10.14 prevents any 32 bit execution at all, so the plugin bridge won't work. 

 

- Do 32 bit plugins still work in other DAWs?

 

- Do ist work if you only load 64 bit plugins?

 

- What happens if you disable sandboxing in the settings (and then restart renoise)?

 

 

With v3:

32bit plugins, when loaded into 64bit renoise, look like this:

Screenshot 2018-06-20 at 23.48.20.png

 

When enabling "run all sandboxed", some 32bit plugins load, but for instance TAL-Dub I & II do not show anything, even sandboxed.

however, i cannot be running plugins sandboxed, as i need to have keyboard input into pattern editor at all times.

 

With v2.8:

Screenshot 2018-06-20 at 23.51.24.png

this is what ValhallaDSP Freq said, before Renoise 2.8 crashed.

not sure which log to look at?

 

okay, plugin log says this:

AU: Trying to open plugin:'Valhalla DSP, LLC: ValhallaFreqEchoMkI' (aufx:FqM1:oDin)...
AU: Setup I/O...
AU: Plugin suggests routing: 1 inputs, 2 outputs
AU: Plugin accepted routing: 2 inputs, 2 outputs
AU: Inputs: 2 (max:1)  Outputs: 2 (max:2) in 1 busses
AU: Setup Rate/Blocksize...
AU: Initializing...
AU: Setup Parameters and Presets...
AU: Start running...
AU: Instantiate OK

AU: Opening editor window for plugin 'Valhalla DSP, LLC: ValhallaFreqEchoMkI'...
AU: Found a custom cocoa editor view component ('ValhallaFreqEchoMkI_AU')...
AU: Failed to create a window from the nib file!

Error Message: Failed to create the plugin GUI. See the log for details.

hope this helps.


http://lackluster.org | on Bandcamp | on YouTube | on Facebook | on Spotify | on iTunes | on TiDAL | on Soundcloud | 

http://twitter.com/esaruoho | http://esaruoho.tumblr.com | GitHubesaruoho@gmail.com | 

| macOS 10.13 High Sierra | MacBook Pro 2.8 GHz Intel Core i7 / 16 Gb 1600 MHz DDR 3 |

| http://renoise.com/tools/paketti | BTC: 1BoZ9rvb8wT7dFNyVPwSX7DLj3stNo7844 | http://paypal.me/esaruoho |

| Latent Impulse Tracker/Scream Tracker 3/Schism Tracker <-> Renoise fanatic |

More API functions, please! ;) http://forum.renoise.com/index.php/topic/26329-the-api-wishlist-thread/page-3#entry240266

#4 Guest_ffx_*

Guest_ffx_*

    Composes without Wires burns Directly from Brain to DVD that is already in Store Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3521 posts
  • Gender:Not Telling

Posted 21 June 2018 - 07:38

Check if those Tal vsts behave the same in another daw, E.g. bitwig, so you now then know that you should blame tal. Happens to me, too, since 10.11. if so, we could both bomb tal support then, if they can fix this (also noisemaker :( )

#5 Guest_ffx_*

Guest_ffx_*

    Composes without Wires burns Directly from Brain to DVD that is already in Store Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3521 posts
  • Gender:Not Telling

Posted 21 June 2018 - 12:45

OMG TAL finally updated TAL Noisemaker: https://tal-software.../tal-noisemaker

 

Or maybe I missed it? It works great again in macOS 10.13, also Renoise, and is 64 bit now!!



#6 Guest_ffx_*

Guest_ffx_*

    Composes without Wires burns Directly from Brain to DVD that is already in Store Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3521 posts
  • Gender:Not Telling

Posted 25 June 2018 - 11:39

Would be nice if the 32-bit-bridge still was working on macOS 10.14 (because AFAIK Apple drops 32 bit support in total).  Such a pity that Taktik never drops in and shares some of his views and knowledge...  :unsure:


Edited by ___, 25 June 2018 - 11:41.