Jump to content


Photo

Rescanning midi devices constantly v3.1


  • Please log in to reply
4 replies to this topic

#1 DerekJDB

DerekJDB

    New Member

  • Normal Members
  • Pip
  • 2 posts

Posted 25 November 2018 - 12:25

I'm pretty sure it never used to do this but lately it's become utterly unusable as I can't do much for it pausing every other minute to rescan midi devices. 

 

Any ideas as to why? 

PS I'm on a windows 7 machine and not a laptop. M audio delta soundcard. Should that matter..


Edited by DerekJDB, 25 November 2018 - 12:42.


#2 gentleclockdivider

gentleclockdivider

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2885 posts
  • Gender:Male
  • Location:something like a sea or a river...just moving
  • Interests:slacking

Posted 25 November 2018 - 12:33

I have the same issue , but it doesn't happen all the time 
Mostly when I lower/close my laptop screen ( I have an external monitor connected ) , 


THERE IS NO RELIGION SUPERIOR TO THE TRUTH


THERE IS NO TRUTH SUPERIOR TO THE ONE I CHOOSE

C'EST MIEUX D'ETRE BELLE ET REBELLE


QUE MOCHE ET REMOCHE



RUBIO RABIA

 


#3 Raul (ulneiz)

Raul (ulneiz)

    Guruh Motha Fakka is Levitating and Knows Everything About Renoise Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1602 posts
  • Gender:Male
  • Location:Spain

Posted 25 November 2018 - 13:26

I'm pretty sure it never used to do this but lately it's become utterly unusable as I can't do much for it pausing every other minute to rescan midi devices. 

 

Any ideas as to why? 

PS I'm on a windows 7 machine and not a laptop. M audio delta soundcard. Should that matter..

 

I can only think of the following:

  • Go to: Renoise:Preferences/MIDI: "Auto-rescan" when hot-plugging devices". Is this checkbox enabled?
 
Is it possible that you have a bad connection with the USB cable or the USB connection ports? Are they loose, dirty, that can cause a bad connection?
 
Maybe in this scenario Renoise rescans the devices that are reconnected. Review the USB ports and the USB cables you use. It could be a very subtle connection failure. It could even be an internal failure of your MIDI device.
 
Make tests. If necessary, uncheck the checkbox... With the box enabled you should not have problems, unless Renoise contains a related bug.
 
You should mention your connected MIDI devices, your motherboard model. Maybe someone with more experience knows how to help you. Personally I recommend you use the rear ports of the motherboard, not front extensions. It also uses the original cables, not additional USB cable extensions.

  • Neurogami likes this

:excl: Development of my tools: Piano Roll EditorKangarooX120SamRenderPhraseTouch

 

:excl: My API wishlist R3.1 (updated 24 July 2017):

Spoiler

 

:excl: My Renoise 3.1 wishlist (updated 26 September 2017):

Spoiler

#4 Neurogami

Neurogami

    Big Super GrandMasta Member

  • Normal Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 779 posts
  • Gender:Male
  • Location:Scottsdale AZ
  • Interests:Art, music, technology

Posted 25 November 2018 - 16:03

A while back I would occasionally have a USB issue with some code I wrote.  A device that was recognized for a while would suddenly seem disconnected.

 

I found a tool that will show USB log activity

 

https://www.nirsoft....b_log_view.html

 

It might help find out if a USB MIDI device is getting disconnected/reconnected.

 

I never seem to have enough USB ports so I added a USB controller, plus my monitor is a USB controller, and honestly they can get flaky as they all use different drivers and such.



#5 DerekJDB

DerekJDB

    New Member

  • Normal Members
  • Pip
  • 2 posts

Posted 27 November 2018 - 10:50

With regard to having dodgy cables. I don't have any connected. I'll try switching off auto rescan. Cheers!