1.5 alpha Render clipping


When rendering a pattern/selection to a Sampelslot there’s quite a lot of clipping happening.
This clipping doesn’t occour when redering to file with precisely the same level settings etc.
I tested both 16/32 bit and the various interpolation methods.

And yes, i preview the rendered samples without any effects.

I can reduce the clipping by not using so many note columns/track.

In this case a have a 5 note-channels worth of drums that are fed thru some effects on a single track. If I spread the drums to individual tracks and process them thru send effects the clipping won’t happen when rendering to sample slot.

Still doesn’t explain why rendering to file doesn’t cause clipping in the first place??(2 different subroutines at work?).

Also redering to sampleslot allways creates 32-bit float samples?
We need options!, mono/stereo, 8/16/32 bit etc.(at least the same options as in render to file).

What about adding ‘render slection tracks to individual samples’ feature?
(the functions are already in place in the render to file dialog).