999 pattern issue

I’ve attached a song. It has a pattern in 0 and 999.
Try follow:

  • add a new pattern below “0” -> you cant error message pattern limit reached
  • switch “0” to “999”, remove pattern from track 1 -> renoise kills pattern “999” and “0”
  • you lost “0”, which is bad

Background about this. I used “999” for resampling stuff. I was programming a pattern on “0”. Now i cant add a new pattern and i cant remove “999” without losing all stuff of “0”.

Edit: “Organize -> Sort Sequence” fix it for me, but why does removing “999” also clear “0”?

No response = no bug?

How exactly are you removing the pattern data? Via the Pattern Editor? Via the Pattern Matrix? Via keyboard shortcut? Via context menu? Via something else?

Which exact version of Renoise are you running, and on which exact operating system?

Do you have any Renoise tools installed that could potentially interfere with pattern or sequence operations?

Anyway… I’m following your steps in Renoise 3.0b8 32-bit on Win8 64-bit, but I cannot seem to recreate the problem you’ve described.

Here’s what happens when I try:

  • Load your song 999pat.xrns
  • Try (and fail) to insert a new pattern after pattern 0
  • Change the pattern number from 0 to 999
  • Delete pattern 999’s content via the pattern editor with CTRL + F3
  • Change the pattern number from 999 back to 0
  • Pattern 0 still contains its original contents
  • All seems fine, and I can now insert new patterns after pattern 0

I tested:

  • right click, clear
  • right click, cut
  • hit del key
  • strg+x

in the pattern matrix on the first pattern block. Every of these steps causing this problem.

I found this problem in renoise b7 and its still there in b8. System is windows 7 64bit.

Thanks for the extra details. I can confirm it’s happening here when I follow your new steps.

This is indeed confusing, but the pattern data is not gone. The “Keep sequence sorted” option will simply swap pattern 999 with pattern 0 to keep the sequence in order.
If you disable the “Keep sequence sorted” option Renoise won’t fumble around with your pattern numbers.

Btw: Using pattern 999 is probably not the best choice for a scratch pattern, because Renoise internally creates all patterns up to the highest one used. So it will create 999 (empty) patterns for nothing in your case. Starting the “regular” sequence at 1, using pattern 0 as scratch pattern might be better then…

Oh ok. Yep a little bit confusing. Thx for the tip. Not sure how you guys will handle this.

Perhaps it is worth a warning mentioning in the documentation.
The Keep Sequence Sorted option is root for a lot of different confusions. (@Taktik:Perhaps disable it by default instead of enable it by default?)