A Few Things That Tripped Me Up As A Beginner

I read in another part of the forum that the dev team was interested in what it’s like to get into the app from a total noob standpoint. First I want to say that this program is very nice indeed. Stable and fast and looks good, which is important to me if I’m going to spend all day looking at it. It’s very seductive … I’m not sure why, since it goes against the entire way I’ve been making music for the last 20 years. But after using DP, Pro Tools and Logic, I’ve come to the conclusion that there are certain things that are just damn difficult to accomplish.

But here’s a couple of things that took hours and hours to figure out…

Entering data in track columns! There is no mention anywhere about how you actually enter numbers in the pattern Editor. (unless I missed it) I get the sense that most of the community grew up with trackers and so assume that any idiot would know how to do this but it needs to be spelled out clearly in the manual. Things like … why can’t I use the number pad to enter numbers? Why does the number 80 show up when I type 8? Why does the pattern editor automatically scroll to the next line, and how do I stop it, so I can enter more data on the same line without using the arrow keys? Granted, I’m a noob. But I’ve been studying this app seriously for the last 30 or 40 hours. It shouldn’t be that hard to find this kind of basic info IMO.

A little more love for Mac users. I understand that this community is windows centric. I’m fine with that. But Renoise runs great on a Mac (as far as I can tell) and Mac users deserve to have a paragraph or two about key commands. Until 3 days ago I could not have told you what Middle Click, Left Shift or Right Control meant. I finally figured it out after not being able to use any of the modifier keys on the right hand side without the pattern starting for an hour or two. Now that I know it, it seems obvious. Yet at the time it certainly was not. On Mac, the hot key for the metronome does not exist as far I can tell. Not a big deal, but could’ve saved me some time. I still can’t get left Control + a number to shift the pattern editor step length. (although I vaguely recall it working once)

I just want to close by saying that I am totally loving Renoise and hope that I’ve brought up some issues that can help new users get into the program more easily. If I’ve just missed something then I guess… my bad. But it begs the question, why is this information so hard to find? And yes, I’ve read the entire manual, the quickstart guide and half a dozen video tutorials.

OK, a couple more things. Drag and drop instantly … doesn’t. You still have to click it once and then drag. Not a big deal but the manual doesn’t describe this accurately. Much more disconcerting is the way the pattern editor keeps jumping focus when selecting a data chunk. Why? It takes my eyes a couple of seconds to realize I am no longer where I clicked. This is the biggest downfall of the program that I can see right now. If trackers are supposed to be fast, then make 'em fast. IF I have a heavy editing session, by the end of the day I’ve probably wasted an hour just waiting for my eyes to re-focus on the new pattern orientation. Or at least have a preference so I have a choice. Or use the pattern follow button. When deselected … the pattern doesn’t go anywhere, no matter what.

This is a lot of things I don’t like (or don’t understand) but there is a lot to like as well which is why I took the time to write this noob review. Also I totally get that this is not a $500 app and so I’m grateful for all the features and stability that is already present. Thanks to all for the great app!


good post. good points. valuable info, i suppose.

i’ve been using the software for about a year now i think, and i did have trouble with some of the points you mentioned. however, i have worked in AXS (tracker) for some time, and got to know all these note-input-things there. there will always be a learning curve. but i agree, the manual could sometimes take less for granted.

I think 99,9% of those question are answered in the quickstart guide (hint: p 12), I won’t say you didn’t read the whole thing, but maybe your inference abilities are not that good… :rolleyes:

Happy tracking and welcome aboard!

I understand what your going through esteso.

I’m basically brand new to Renoise (owned it for 5 odd months but just started to actually use it) and Trackers as well. I was using a few other DAW’s but today I’ve made the choice to just focus on Renoise and nothing else.

The jumping focus thing frustrated me as well to no end; is there anyway to turn it off?

Overall I’m finding it to be a shitload of fun to make new songs, I’ve got a gig coming up next Saturday and I’m going to see if I can do it all with Renoise.

Also being a software engineer by trade the possibilities in 2.6 that have opened up are amazing!

That quickstart PDF guide is helpful, but it seems like it’s located only on the tutorials website (a download link at the very bottom).
Perhaps it would be a good idea to show it more prominently?

@esteso: did you try using the single-click/alternative drag-methods? Check this link for more information

It’s included with Renoise, in the binary package…

Hey you’re right, it’s there right next to the Renoise program file…

View => Lock keyboard focus (you will still be able to set the focus anywhere by middle-clicking with mouse or LALT+leftclick)

“Focus” was an unfortunate word. That’s not what I was talking about in my original post. Keyboard focus is not the issue. The issue is that the pattern editor keeps jumping around whenever clicked, creating an unsettling feeling of never knowing where you are. I understand that a lot of you guys are used to this but coming from more mainstream daws makes this tough.

PS I did RTFM twice! The Quickstart guide does not answer any of my questions posited in the first post. Nor does the other manual. If you think it does, prove it and show me the page.

edit: Well it looks like I was wrong about one thing anyway. The increase edit step by 1 is set to Command =, not Control =. Oops. mea culpa.

PPS None of this stuff is going to stop me from buying this.

I’m just going to start a new post for this one 'cause I think it’s important, re: entering data.

Say I want to retrigger a sample so I go to the FX column and I want to enter 0E04. So I position my cursor on the first section and hit zero. Nope, that doesn’t work so I scour the manual and find that zeros are entered automatically. OK fine. So I scroll back to the original line, scroll over to the second column and enter “E” Now 0E00 is entered. OK, pretty close, except the cursor has moved again and I have to scroll back to the original line once more, scroll over to the last position and enter “4” and I’m done.

Pretty nuts. That’s a lot of scrolling to enter one simple line of data. I’m sure you can get used to it and think it’s easy. But a much easier way to do this is to simply have an option in the prefs that allows you to stay on the same line if you want. Just bind it to a hot key, end of story. If I’m missing some sort of workflow suggestion that makes this point moot I’d love to hear it.


Ah, if there’s one thing team members will always provide, it’s suggestions :slight_smile:

Hit CTRL+0, this should set editstep to 0, and have the desired effect. Rock on!

Just set the step length to 0 (yellow arrow). There you can set the wanted number of lines to jump if you enter any data. If it is set to 0 you avoid line jumping ;)

yes, i ran into this when first using Renoise as well. i still don’t know why you can’t use numpad to enter numbers. does not make sense to me.
as to why ‘80’ shows up when you type ‘8’: go to Edit > Preferences > GUI > untick ‘hide 0’s in effect columns’. i find this setting to give you a very cluttered effect column, but it does show you the answer to your question. the 0 was already there. this also goes for your other remark about entering a 0 on the first position and getting no result. this tripped me up in the beginning as well. now, (after about a year), i don’t even think about it anymore.

this confused me in the beginning as well, and still does sometimes. i don’t know why this behaviour is the way it is. i learned to accept it. i agree with you completely on this one.

honestly, because you pointed this out it is the first time i noticed this behaviour. trying it out i can somewhat understand your confusion. it would be nice to have an option to switch this behaviour. however, i think this was done to make sure you are always working in the middle of the screen, so to speak. if this behaviour became optional, what would happen? would the editor do a page-down on moving to the first position outside of the viewing area? or would it just move a single step down? how do you envision this?

by the way, welcome to the community. as you might have noticed, there are a lot of people more than willing to help you in any possible way. a lot of things take some getting used to and are really not that bad afterwards. keep up the good work.

Awesome!! Thank you (both of you)

OK, thanks. That makes sense in a way after unticking the “hide zeros” I can see the defaults. Good to know.


Well my first idea is that the window would simply not move. It would be possible to need to edit off screen but this is easily remedied with the scroll wheel. The screen can still move in the way it does now. It’s just that when initially selecting a data chunk or area the window would not move at all. I’m perfectly willing to accept that I just need to get used to it 'cause it’s not going to change. It’s just very foreign from a daw standpoint.

Thank you, I’m happy to be here and getting to know you all. With all these niggles that I’m pointing out I just want to re-state that there is something about this program that is very seductive. I’m not sure what that is but I’m hoping it will allow me to go into some new areas in music just by virtue of working in a completely different way.

from reading this i gather you’re workflow is (still) very mouse-oriented. a lot of people work with the keyboard inside the pattern editor. so when you say that something is remedied with the scroll wheel, the first thing i think is ‘what about people who do not use the mouse?’ - what i’m saying is, when you adress a certain issue with the current system, the need for a workable solution logically arises. think about how it could be done differently, and maybe better, and make a post about that in the ideas/suggestions forum… right now, i do not see a solution for this (taking into account both the keyboard- and mouse-users). unless you do have a solution, i think you should, as you said yourself, indeed accept this behaviour.

I don’t understand this statement, could you make an example? No matter where I click in the pattern editor, the editor stays where it is, it does not scroll or anything,


are you in edit mode? it does not do it when not in edit (recording) mode (Escape-key on PC). then click on a random position on a random track, and repeat. you will see how the position you clicked is being centered (to test this, put your finger on the screen parallel to the selected position, and start clicking. you will see the editor jump around, while the selected position stays in line with your finger (centered).

Hello there, I guess we are using different words to describe this behavior. The way you describe this is what I mean by jumping around. Yes, the cursor stays centered. This is not what I would like. I want the window behind it to not move so my eyes don’t have to jump to a new spot on the screen every time I click somewhere with the mouse. Now, if you move the cursor to the “top’ of the pattern I’m about 4” from the top of my screen. That’s a waste of space. Let’s say I decide to edit line 55. I select line 55 and now that jumps 4" from the top of my screen too. I was expecting it to be on the bottom where my eyes were focused. It takes me a second to realize what’s just happened. It’s disorienting and unnecessary. I want the lines to not move unless I tell them to. Furthermore, if I select line 63 to edit, I can only see up to line 36 in the same pattern. The top of the pattern is unavailable to view or to edit.

I just can’t see the point. Give me an option to lock the pattern with a key binding so I can choose which scrolling behavior is appropriate for the task at hand. Make sense?


try unchecking this: Edit => Preferences => Gui => Single mouse click navigation". If I got what you mean, the pattern will “jump” only if you double-click it