Are there problems with dongles and Renoise?

Hi

I have not been using daws for years, so perhaps this is a general problem.

I recently bought Renoise 3 and Cubase 7.5 and a Windows 8.1 pc and everything is 64bit.

Problem 1:

My plugin called soundtoys Echoboy worked fine with Renoise until an hour ago. Now it fails to initialize in Renoise. When I open it up in Cubase there is no problem. I have no idea why it has stopped working in Renoise. It is activated. the license is on an iLok dongle. Is that the problem?

Problem 2:

When using Renoise then after an hour or so then one of my elicenser plugins stops playing and the message is that it should be activated in order to continue using it. However the plugin IS activated, which I can see in elicenser. The plugin is Arturia Spark.

With Cubase I have not experienced these problem, yet perhaps? or is this an issue with Renoise?

Best regards

Max

Ok. I fixed it. I switched off the plugin sandboxing in the preferences, and now I can load the soundtoys echoboy plugin without the loading failed message.

Weird, but great! Renoise is my favorite daw.

Max