Audio Unit

I place a plugin component, let’s say magical8bitplug, int: Library/Audio/Plug-Ins/Components
What I do now to make appear? :(

  • the man not worthy of his imac

Which version of Magical 8 bit plug do you have? The Universal Binary one?

Both, actually… just to be sure…

Okay, so iamdoinitrite? Then why doesn’t Renoise pick up ANY of my plugs? :(
They’re in the ‘Library/Audio/Plug-Ins/Components’ folder as .component

Any help would be appreciated!

If your iMac is PPC then you need to downgrade to Renoise 1.5.1, Renoise does not support PPC plugins anylonger since 1.5.2.

Aight, thanks for the clue! :) Do you know how I can find out if my iMac is PPC? What IS PPC…? And do you know why Renoise stopped supporting it, if it is vital for plugins to work…?

You’re Mac is probably not a PPC. Those are G4 and G5 computers.

Did you go into the Renoise preferences and check whether or not you have Audio Units turned on? Did you try rescan?

They work fine on my computer. I put them in two different directories. These are my current AU plugins.

$ ls  
Automat.component OctaveShifter.component daHornet.component  
Automat1.component TAL-Dub-2.component  
KTGranulator.component TAL-Dub.component  
AmpegSVXUNO.component TRackS1.x.component  
AspectAU.component TRackS1.xClipper.component  
Crystal.component TRackS1.xCompressor.component  
Discord 2.component TRackS1.xEqualizer.component  
DubStation_15.component TRackS1.xLimiter.component  
PlastiCZ.component Trash.component  
Slayer2.component quadraSID.component  

Replace dac514 with your username for the first path. As a side, please note that VST plugins should go in ~/Library/Audio/Plug-Ins/VST, not the Components folder.

If all else fails. Delete your preferences folder. Maybe something is corrupted. By deleting the preferences, Renoise will regenerate the defaults on startup. E.g.


Huh?! Absolutely false. Is this a joke?

Thanks a ton, Dac! I did check the AU-checkbox and turned them on, also tried rescanning several times, but I’m going to double check the path… maybe somehow I forgot to add Users/Jordy/ in the path… I don’t know…

Ironic that, when I switched to OSX, I deliberately waited with installing plug-ins, so I could focus on mixing-skills and sounddesign, before tackling synth programming. Now I can’t get the damned things to even show up in Renoise :D <- me laughing at irony

Also check the permissions of your plug-ins. Maybe you copied them in a way that Renoise can’t read them.

  • Right Click A Plugin -> Get Info
  • Under “Sharing & Permissions” make sure you have something like:
  • (me): Read & Write
  • staff: Read
  • everyone: Read

Same thing for the actual directory. Also run “Disk Utility” and do “Repair Disk Permissions” for good measure.

Aight, thanks a bunch again for your help!! Will try those things, too :)

Sorry Dac, that’s absolutely no joke, section 1.5:

Huh, I learn something new every day.

Well, despite all hope, love and friendship… I didn’t get the magic8bitter to show up; I tried both versions, in two different directories, AU enabled, rescanning, rescanning again… I guess my iMac IS PPC…? I downloaded and installed Reaktor 5 demo and this one DID show up, without much hassle.

Anyway, thanks again for your help, guys! I was afraid I was epically failing in installing the actual plug-ins, I figured I had to do something else with the component-file… but maybe I still am worthy of my iMac :P

I’ll stick to using Renoise’s square, triangle and sinus samples for chip-sounds :)

If you want to know for sure if a plugin is PPC, you can always install a copy of Renoise 1.5.1 and use that to see if the plugin does show up. If it does in there, you can be pretty sure.
Perhaps Taktik could consider to scan all plugins and enlist the PPC plugins as well but disallow selection of them. I have no idea if this is hard to do. But at least you can be sure that you installed the plugin properly, you just can’t use them.

Oh well, who needs magical 8 bit plug when you JUST BOUGHT REAKTOR 5 FOR 99 EUROS :D


Ho shi-
Reaktor get - massive get

Paypal error :( I hope they fix this