Autosave Is Somewhat Broken


I’ve reported before that during autosaves that occur on playback, sometimes (this isn’t happening every time) the sound gets silenced. This is kind of an annoyance since often long pad sounds, initialized a couple of seconds before must be replayed.

The devs told me that this behaviour can’t be changed since some VSTs will crash if playing during song saving. Fair enough. I switched off the Save While Playing option. It should solve the problems, right?

Yeah, kind of. The quirk with SWP turned off is that when the backup triggers at playback, it is simply discarded. So if you want to make backups every 10 minutes, have the SWP option turned off, and you are unlucky, the odds are backups are made every 100 minutes, or so. In my case, doing backups every 10 minutes gives in reality backups every hour.

And no, setting autosaving every minute is not an option: saving takes time (a second or so) during which I can’t do much (this is very disk and CPU intensive on my laptop). Plus, to have a reasonable time span with these backups, I’d have to keep a hundred :blink:

I’d have a couple of ideas how to solve the situation. The simplest being:

  • backup triggers but the playback is on
  • backup waits for stopping playback
  • on stop, backup is done immediately
  • if no stop before next backup trigger, the old one is discarded (Renoise could warn the user on the status bar like this: “A single backup was discarded because of continous playback for N minutes.”

I have also some other ideas but these are somewhat more complicated (partial backups during playback, RAM backups, versioning support, etc.).

What do you think?

Ambivalence: I agree. I’ve been thinking of a “solution” in the same terms. The point where it’s best to be interrupted by autosaving is after you’ve stopped playing a song.