Can't install Renoise on Kubuntu 64-bit

Hey! I recently downloaded renoise to try the trial version, although I came across this odd bug…

I tried to install by unzipping the tar file and running the .sh , which worked fine at first, although when it started downloading the program, I noticed that the percent gauge was jumping around, Showing 33%, immediately swapping to a larger value like 67%, then jumping back down to 34% after, and just flip flopped around until it was finished. (Now sure which one reached 100% first, as I let my computer idle)

Once I returned, I noticed that the installer disappeared and there a lot of error messages popped up, but I don’t quite remember what they say.

When I tried to run the .sh again, I just get the error:

File is larger (3094235525B) than expected (1549666693B)

Can anyone help me out with this?

The .sh script started to download something?!

Is it not supposed to?.. I’m honestly really lost in all of this.

I haven’t downloaded the demo in a long time but as far as I know it’s the same as the full version in how it downloads and installs. Download the file from here, extract it, then run the .sh install script, it should just install it to your system (by copying files to appropriate locations, not by downloading anything). Or you can run it directly from that extracted folder as far as I know.

it’s downloaded and installed! Thank you so much!