Caps Lock Question

Hi there,

here is what happens:

I go into recording mode (ESC), I enter one note, followed by one note Off (by using the Caps Lock key). I then hit ESC again to exit recording mode. I then click on the track name and change it into “mytrack”, but the result is “MYTRACK”.
“Of course, you have caps lock switched on” you might say now, and sure, that is the reason.
But if we use this key for note-offs, then one would expect it to have ONLY this function!
If there is a way to (at least inside Renoise) to disable locking the caps, then this should probably be done, if not (and I think that is probably the case here), because this is somehow handled by the keyboard itself, then the Caps-Lock key might just be a very bad default key mapping for note-offs :)

What do you think?


i have CapsLock disabled permanently on my laptop through an AutoHotKey-script, so i would’nt know of your problem.
however, the biggest disadvantage of using the CapsLock-key for note-offs is that (in my case) it only triggers the setting of note-off when CapsLock is set to ‘yes’ (or ‘lock’, so to speak). in other words, i have to push the key twice to get the note-off. is this normal behaviour, or could this have something to do with my AutoHotKey-script interfering?

if this is normal, you probably get my point: i don’t understand why i have to click twice.
also, to my knowledge, it is not possible to assign another key to this function. so it would be only logical i guess, for both our problems, if there would be a possibility to change the key for note-offs.

Whenever I have caps-lock enabled, it is automatically disabled as soon as I begin to edit any kind of text field, such as a track name, instrument name, search box, etc.

It is only when a text edit field is already active and has focus and THEN I press caps-lock, that caps-lock actually stays on (as it should in this situation).

I even tried the exact steps you just described, but I could not recreate the problem. :unsure:

Definitely not normal. Every time I press caps-lock, a note-off is correctly inserted, no matter if caps-lock itself was enabled or disabled at the time.

Preferences > Keys > Global > Transport

(Not sure why it’s in Global rather than Pattern Editor, but here it is anyway)

I have never heard of such a feature? Is this for you in Renoise only or system wide?
Whenever I hit Caps-Lock here, then the light on my keyboard (or on my laptop front, whatever I am using) is switched on and stays on as long as I hit Caps-Lock again.


Everything I mentioned here applies only to Renoise.

All I mean is that Renoise is intelligently disabling caps-lock before I edit any text fields, track names, etc., so it does not matter what I have been previously doing with note-offs in this case, and I do not experience the problem you’re describing.

If I’m already editing a text field and then I press caps-lock, then caps-lock does indeed stay on, which is exactly what I would expect to happen.

It’s “normal” for Windows 7 x64 (see this thread), and a bug in Renoise which so far hasn’t been fixed :(

Most likely yes, as you have configured AutoHotkey to mangle with this key, there is a big chance it also changes the behavior in other applications.

This is definitely not what happens here on my Linux machine! Renoise is not intelligently disabling Caps Lock at all. Caps Lock is always triggered, irrespective of where I was, be it a text field or the pattern editor. Very annoying.


Happens to me too (have to press caps twice for a noteoff), glad this got brought up actually - I’m on W7 x64 too.

*edit - just read the other thread - caps not possible anymore?!?! I guess ‘a’ will have to do, but I hope MS can make W764 behave like the other versions though, this is quite a change in some respects!

So is this now a bug in the Linux version, or what is going on?


You can call it like this. This is not implemented on Linux because I found no way to do so.

Never mind, just figured out it can be fixed on the user side with:

xmodmap -e "remove lock = Caps_Lock"