Computer Completely Freezes Up Computer When Rendering With High Prio

Ey, move this to another forum if you wish…but err, was rendering some tracks on perfect arguru setting & realtime plugin compatible mode (16 bit, 44100, entire song).

In my vague memory of past 1.9.1 experience :slight_smile: the same settings would allow me to still browse mozilla, do some minor other stuff. Right now, rendering completely freezes the comp, causing the mouse pointer not to move + computer time clock to freeze for at least 6 minutes on one track. Normal behavior?

I know realtime plugin compatible mode + arguru settings are the heaviest on computer cpu load, but they seem to render more agressively now. Also, the progress bar doesn’t update consistently when rendering, sometimes it jumps from like 19%, to 56% after 5 minutes of freezing. Sorry if this is placebo, it doesn’t feel right :slight_smile:

Control Panel > System > [Advanced tab] > Performance > Settings > [Advanced tab]

Under “Processor Scheduling”…

Make sure that “Adjust for best performance of:” is set to “Background services”. This should help to keep things smooth when you’re browsing, emailing, etc., while Renoise is rendering in the background.

If that doesn’t seem to help much, then I guess it really is just down to Renoise’s render priority.


Yes, Renoise high prio modes are more aggressive now. Couldn’t you simply use the normal prio mode if you want to do other stuff in background?

Better, bring up the task manager and set Renoises priority to one notch below “normal”. When other programs are not using the CPU much (which is usually the case when browsing, unless you surf to newgrounds or myspace etc.), Renoise will run at full speed, but it will not slow other apps down when they need some CPU lovin. This might not always be a good setting for composing or playing live, but for renderingg it’s so good I wish Renoise could do that on it’s own! It works much better than low priority rendering, which is kinda slow even when other apps are not using the CPU.

Smart trick Johan, I’ll try that next time or simply use a normal prio. Already have the background services thing running here.