Cpu 99.9% ?


It wasn’t doing this before, but now, I can’t make my songs without having to render if I want to preview my work. It’s kind of boring to work on a song when you have to wait minutes before hearing something that is not what you want, so you have to change something and render again…

Before, when I was rendering, I was using the “High (as fast as possible)” and it was going very fast. Now, when I render, it’s going realtime! why??

When I play my song in renoise, the CPU sometimes goes up to 99.9% even if I only let the kick to ON ! in the kick track, I use the 5band EQ, and I got the Sidechain compressor from Db Audioware. that sends it to my synth track that also have this sidechain vst… but I was using this technique before, and I wasn’t experiencing lags…

I got a dual core processor and 2GB RAM…

Sometimes, let’s say once in a month, renoise will not lag for about 5 minutes… it’ll be perfect like it used to be! and then I will press stop, I will tell to my friend “hey it’s not lagging anymore!!” on msn messenger and i’ll come back to renoise and It’ll lag and CPU will go up to 99.9%.

My friend also got his copy of Renoise 2, and when he use the same vst’s that I use, he’s not experiencing any lags, on his laptop with 1GB RAM… WTF?

PLEASE, help me!!!

Thanks a lot !!
Marc Rémillard

lol @ nickname :D



How are your power settings in your platform configuration?
Do you use a laptop or a PC?
Does Renoise 1.9x behaves the same?

If you use a laptop and have power-savings configured on it to change the CPU voltages when idling, this can cause annoying behavior in cpu resource consuming applications.
Can you remember any specific changes that you made close to the moment the problem started to occur?

Is this only about rendering? Rendering accesses the disk, probably you are running out of free space, have a very fragmented disk…
Or do you render because of the CPU spikes?
Have you tried using different Audio latencies (Preferences -> Audio -> Latency)?