Dirty Sound With Jack?

Hi all,

if I choose in the Renoise preference dialog JACK and not ALSA, I get a realy dirty and noisy sound playing my mods. Without doubt it could be a cool feature for noisecore producers :D, however I don’t intend to produce only noise with Renoise. If I switch to ALSA everything works great. I’m a little bit surprised that I still don’t see a similar bugreport, so I’m not sure whether it is a bug at all or just wrong configurations or something like this? Any ideas?

Thanks in advance!

PS: My configuration: just a standard Ubuntu 7.10.

Do you get this dirty sound with other apps using Jack? Like ardour for example.

Check the JACK for XRuns. If you have lots of them, it is possible that your jack is just misconfigured. (On some cheap soundcards Jack can’t get decent sync with soundcard input and output. So if you set your soundcard to “play only” in QJackCtl (for example) settings instead of “Full-Duplex” the noisecore goes away.)

Realtime audio with jack requires a realtime kernel.
You should install the ubuntu studio kernel.
https://help.ubuntu.com/community/UbuntuStu…radingFromGutsy

First, thanks for you answers!

Ok, I’ve suspected that it could have something to do with my non-real-time kernel. However, as far as I know, the Rhythmbox uses jack per default if it is installed and I have no problems with sound there, it works even better than with Alsa.

I will install the real-time kernel and report about the result.

Another thing to check is the buffer size that Jack runs with. Have you already tried to increase it? Also make sure that you use ALSA via Jack, not OSS.

In summary:

  • install a real time kernel if possible

  • make sure you use ALSA with Jack (OSS is outdated and thus emulated in most cases)

  • do not choose “default” as device in Jacks ASLA config. Use a “HW:X,Y” device instead. The “default” device might be emulated and slow

  • make sure you choose an appropriate buffer size (try increasing it when you get crackles / XRuns). Alternatively you can try to increase the number of periods per buffer while keeping the buffer size small.

  • try if disabling the record (input) device (not running full duplex) helps…

Rhythmbox does not use Jack by default.

Also, you should not allow programs to start jack by themselves. Use Jack control application like QJackCtl to fire up JACK. First of all, this allows you to set Jack settings, second, it gives you better debugging output.

For additional information:

  • Jack is not a sound driver itself.
  • Jack is a sound daemon which allows you to connect programs HW devices. And which provides realtime audio signaling and synchronization framework.
  • Jack USES Alsa. So if you run Renoise with Alsa drivers your rig will look (Renoise → Alsa → Soundcard), if you use Jack drivers it looks like (Renoise → jackd → Alsa → Soundcard).

Also for clarification: Setting up realtime kernel won’t fix garbaged sound. It fixes occasional glitches in sound that may or may not happen in non-realtime kernel. If you get garbaged sound you definitely have Jack misconfiguration and setting up realtime kernel won’t fix it instantly.

I had the same problems with some onboard sound cards. They always (different jack settings) produced some cracking noise. The only solution was to buy some “real” sound card. An easy way to test this, is to play back some sample in Ardour because it uses Jack for sure…

Ok, it was enough to increase the number of “buffers/periods” in qjackctl from 2 to 3 and the noise disappeared. Many thanks to you all!

btw: yes, I have an onboard sound card.

Will have to try the tips recommended here, seems I’m having similar problems.

It works ok when I’m just doodling with one note at a time but say I have three notes playing at the same time or any more and it goes slow motion and crappy. I’ll see tomorrow if any of this helps.