DiscoDSP Discovery native Linux VST Problem loading


VST Plugin (DiscoDSP Discovery / Demo Version) is not loading, Errormessage:
“Internal Error: Failed to connect to the external audio plugin process (could not establish a connection to the server).”

Current Config:
Crunchbang 11 (64 Bit standardconfig with jack and so on)
Renoise 2.8.1 (64 Bit)

Anybody an idea?
I actually want to buy this one rather than Aspect Loomer. This does not mean Aspect Loomer is no good, it is great, but i know the Nord Lead 2. Get the Plug here, Demo Download. Thanks for any Feedback


Replying to this since I’m having a similar problem with Mr. Alias 2 on 3.1.0, running BunsenLabs RC1 (successor to Crunchbang). I get the same error message when I scan for VSTs. The other reading I’ve done about this seems to indicate that the plugin is simply crashing on load. I thought it might be due to my plugin being 32bit and Renoise at 64, but I tried the same thing in the 32-bit demo version and get the same result. Concluded that the plugin was just buggy and couldn’t be implemented that way.

So I found a workaround that might work out for you, using dssi-vst and the Windows version of the plugin (you can do this accross the bit barrier). Try this:

sudo apt-get install apt-transport-https software-properties-common wget
wget https://launchpad.net/~kxstudio-debian/+archive/kxstudio/+files/kxstudio-repos_9.2.2~kxstudio1_all.deb
sudo dpkg -i kxstudio-repos_9.2.2~kxstudio1_all.deb

sudo apt-get install wine dssi-vst dssi-vst-bridge

That adds the KXstudio repo to your apt, and then grabs dssi-vst from there. Once that’s done, grab the dll for whatever VST you want to be using and do

vsthost [VST].dll

That’ll fire it up in its own window, outputting to jack. Then, just use jack to route the audio from vsthost back to a channel in Renoise, and MIDI from Renoise to vsthost, and you should be good to go. I know it’s a kludge, and makes you sadface that a native Linux VST isn’t hosting right in Renoise, but it functions.

EDIT: you can also invoke vsthost with a -n flag for NoGUI. Less load on the system.