[done] Midi Note Entry Improvements...

Well, now I see what people are complaining about.

Right now one has TWO choices if he or she is entering notes with a midi device:

  1. One note polyphony no matter what. No matter what.

  2. Chord mode, always, so if there’s a note already on the column, and you’re sequencing, as in not entering notes live while the song it playing, it won’t act like it does with the keyboard and cover the note that you’re on, it will always go in the next column instead.

It really should act like it does when one enters notes with the computer keyboard. I shouldn’t have to constantly toggle between chord mode and not chord mode.

Here is a quote from myself in the alpha testing, it would address the issue that you are talking about or not?

Basically Ignoring pattern data + a visual aid for comfort

EDIT: Clarified quote (italics)

Another thing that could be done is so when it is not in chord mode, when entering notes LIVE, like when the sequence is playing, it would be in polyphonic entry mode. I can’t see a reason why someone would want to enter notes live, when a sequence is playing, in a way that wouldn’t allow chords.

I suppose I could just get used to having to turn the chord option on and off on a regular basis, but I never had to before…

If you are entering for example drum notes that you want to keep in the same column (and not recording note-offs) could be a situation.

In any case I re-submit my request above with the hope of beta test support :)

Thanks. Yes, that would be a good modification for sure–at first I didn’t fully understand what you had said. Yes, absolutely, notes that are already in the column should clearly NOT be a part of the “chord mode”.

Also, if I’m not in chord mode, and I’m not in record mode–I’m not actually entering notes into the sequence–I should be able to play and hear more than one note polyphony.

Can i ask why in this case, as usually to me this is further feedback as to what mode I am in?

I guess it won’t really matter once the chord mode is fixed.

Not being able to go back and fix or change a chord without turning chord mode off is not a minor annoyance, it’s a major, MAJOR hindrance.

Just so people reading this know:

If I wanted to enter a new note where the cursor is sitting, like a G#5, unless I hadn’t used the enter key to hear the chord above it, there is no way to enter a note where the cursor is sitting unless I turn off chord mode. This is a major hindrance. MAJOR.

EDIT: Is there a quick-key for chord mode, one that doesn’t require pushing 2 or 3 keys to access? If that was available, this wouldn’t be so bad…

Agreed! :)

there is the minor workaround for your screenshot example, of pressing PANIC (stop twice or assigned shortcut) in the meantime for this. This will reset the note-offs and you will be able to enter notes where the cursor is [still an annoyance though IMO]

It is an assignable shortcut (can`t remember what the default is here as I re-assigned already)

That’s not really a workaround since doing such would stop me from hearing the other notes in the chord while I enter a new note. The point was being able to hear the notes while I enter the new one.

Where would the chord mode be in the keyboard shortcuts preferences? I generally don’t mess with that since there are thousands of options there and I never know where the options I’m looking for are located. Would this be in global (application, document, view, transport, song control, instruments), mixer , pattern editor, pattern matrix, or pattern sequencer?

Another thing that has been removed is the ability to hit the notes individually to make up a chord like one could before–I used to be able to hold the shift key and enter the notes individually of the chord without having to hold each note in the chord down for it to go to the next column. Also, if it’s a real stretch of a chord, I have to set the editstep for 0 and enter each note and tab to the next column manually whereas before I could simply hold the shift key.

Unfortunately that`s the best I can suggest in the current incarnation…

There is a new All filter (or no filter) added: just type in chord to the search and you will see it.

Yes, this only works for qwerty keyboard entry. I agree that it should be kept for MIDI also, as I see no obvious conflicts if my solution above were to be implemented?

Yes, thanks :)

If this ends up in its current incarnation in the final release, I will not be using 2.5 or beyond until it gets fixed. I play by ear and having to hit space to stop the notes from playing in order to enter new notes in the same column is horrible.

Don’t panic. Lets please try to finetune the new mode to make everyone happy, instead of adding such options as workarounds: