Energy Xt Wont Shut Up

so I tried this trick with energy XT as VSTi to play long wavs, works quite nice, but the problem is that the VSTi is immune to trackmuting … I assign Energy to any track, it plays fine, but when I mute that track energy is still playing. :(

That’s because it acts like an external piece of software synced up to renoise. Although you can route the audio stream to a track by assigning the VSTi to a track and apply effects to it, you’re not actually triggering the audio in the track. Therefore, you can’t mute it.

I just put a Gainer at the end of the DSP chain set to zero and enable/disable it as a workaround.

yeah, I did that too, just wanted to know if there is anything I do wrong.

If you use mute instead of off with this method it will work but XT will carry on using processing power.

found that out myself too in the meantime … strange thing :)

edit: obviously it works this way : if you mute a track, the output after the FX chain is simply set to zero, when you disable a track then the notes in the pattern wont get triggered and renoise just auto suspends the fx when there is no signal left. if I use overdubber in a track and disable this one, overdubber still plays it echoes, when I mute it it gets turned off instantly.