Extracting Renoise on OSX

Having some trouble installing Renoise! I’ve installed on Windows and Linux before, but for some reason I’m running into errors extracting the renoise tar.gz on OSX.


tar -xf rns_3_1_0_osx_64bit.tar.gz

Spits out

Renoise_Reg.app/Contents/Resources/Library/Multi-Samples/Comb/Additive7 Samples/ZAdditive7_F#8.wav: (Empty error message)

tar: Error exit delayed from previous errors.

I tried extracting with Archive Utility as well, but got “Error 1: - Operation Not Permitted”.

I then tried to run the half-extracted result from these, but it either hangs on startup or spits out an error stating that there are missing fonts and such.

Am I doing something wrong? I’m new to Macs so it might be something silly, but I’m not really sure how else to approach this. Any help would be appreciated!

Thanks a bunch :slight_smile:

Sounds like a file permission problem? Drag the archive on desktop first and unpack there, by double clicking it. Then move the app to applications. Or do you extract on a fat32 partition? Try a hfs partition then.

I think you need “tar -xzf” when it’s a .tar.gz (.gz = zipped, -z = unzip)

Tried moving it to Desktop and extracting from there, but that didn’t change anything. I’m also not sure how to manage disks, but I’m assuming since this is a new computer, OSX is likely not using a fat32 partition.

I also added the -z flag as pat suggested, but that too didn’t change anything. I’m still getting the exact same errors!

Fixed!! Turns out the solution was simply downloading a new copy of renoise. I guess the download was corrupt in some way!

How crappy is the tar.gz format then?? If it simply was a zip, the unpacker would report if there was a checksum error. Why the hell Linux world still uses tar.gz??

ffx: I do believe there is a 32-bit crc checksum with the gzip format. I created a tar.gzip ball and corrupted one byte in the file, then tried decompressing the archive. Linux reports:

gzip: stdin: invalid compressed data--crc error
tar: Child returned status 1
tar: Error is not recoverable: exiting now

gzip caught the bad checksum and tar couldn’t complete.

Another thing to quickly mention (that might have a slight effect here), Mac OSX is based on BSD Unix so I assume when you run ‘tar’ you are running not Linux ‘gnutar’ but BSD ‘tar’ on a (I assume) Linux ‘gnutar’ file?

Normally a tar.gz decompresses just normally here on osx. I really wonder now in what way the download was corrupted??

I really wonder now in what way the download was corrupted??

Not sure at all ffx. Just thinking a little further. You would have to take the internet transmission out of the equation as much as possible by having the server report what say the MD5 checksum is on the personal ‘zip’ file it gives you from the backstage. Then the user can compare by running MD5 on the file received.